Bug 215396 - kernel-pae does not have software supend activated
Summary: kernel-pae does not have software supend activated
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 6
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 505247
TreeView+ depends on / blocked
 
Reported: 2006-11-13 19:30 UTC by Till Maas
Modified: 2009-06-11 07:19 UTC (History)
3 users (show)

Fixed In Version: 2.6.20-1.2925.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 505247 (view as bug list)
Environment:
Last Closed: 2007-03-19 20:55:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Till Maas 2006-11-13 19:30:08 UTC
Description of problem:



Version-Release number of selected component (if applicable):


How reproducible:

always

Steps to Reproduce:
1.
$ cd /boot  
$ diff config-2.6.18-1.2798.fc6 config-2.6.18-1.2798.fc6PAE 
3,4c3,4
< # Linux kernel version: 2.6.18-1.2798.fc6
< # Mon Oct 16 14:34:53 2006
---
> # Linux kernel version: 2.6.18-1.2798.fc6PAE
> # Mon Oct 16 14:51:42 2006
190,191c190,191
< CONFIG_HIGHMEM4G=y
< # CONFIG_HIGHMEM64G is not set
---
> # CONFIG_HIGHMEM4G is not set
> CONFIG_HIGHMEM64G=y
193a194,195
> CONFIG_X86_PAE=y
> # CONFIG_NUMA is not set
229,230d230
< CONFIG_SOFTWARE_SUSPEND=y
< CONFIG_PM_STD_PARTITION=""
1368a1369
> CONFIG_I2O_EXT_ADAPTEC_DMA64=y
3333,3336d3333
< 
< #
< # Page alloc debug is incompatible with Software Suspend on i386
< #

Actual results:
[...]
229,230d230
< CONFIG_SOFTWARE_SUSPEND=y
< CONFIG_PM_STD_PARTITION=""
[...]

Expected results:

No difference in the activation of software suspend since it is not mentioned in 
http://fedora.redhat.com/docs/release-notes/fc6/en_US/sn-Kernel.html#id2840748

Additional info:

For notebook users pae may not be imported but the No eXecute feature and the
suspend feature of the kernel are. For this reason both features should be
accessable or at least it should be proper documented.

Comment 1 Dave Jones 2006-11-25 03:19:16 UTC
PAE & suspend are incompatible in 2.6.18.  I believe this has been fixed for
2.6.19, so when I backport that after its release, this should be fixed hopefully.

Comment 2 Mihai Harpau 2007-01-12 12:04:29 UTC
Situation is the same in kernel-PAE-2.6.19-1.2895.fc6 from updates-testing:
software suspend is disabled. Any reason for not activate it?

Comment 3 Nigel Cunningham 2007-02-20 21:56:12 UTC
As far as I know, swsusp still doesn't support PAE at 2.6.20.

Comment 4 Thorsten Leemhuis 2007-03-02 07:04:43 UTC
(In reply to comment #3)
> As far as I know, swsusp still doesn't support PAE at 2.6.20.

2.6.20 should support it afaics:
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=2d4a34c9365c6e3f94a5b26ce296e1fce9b66c8b


Comment 5 Dave Jones 2007-03-19 20:45:10 UTC
Indeed, it should be present in the current builds..

configs/kernel-2.6.20-i686-PAE.config:CONFIG_SOFTWARE_SUSPEND=y


Comment 6 Till Maas 2007-03-19 20:55:42 UTC
(In reply to comment #5)
> Indeed, it should be present in the current builds..
> 
> configs/kernel-2.6.20-i686-PAE.config:CONFIG_SOFTWARE_SUSPEND=y

$ uname -r; ls /sys/power/
2.6.20-1.2925.fc6PAE
disk  image_size  resume  stat

Yes, this bug is resolved. :-D


Note You need to log in before you can comment on or make changes to this bug.