Bug 215449 - seg fault on start after upgrade
seg fault on start after upgrade
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-13 20:06 EST by JLapham
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-14 20:55:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description JLapham 2006-11-13 20:06:21 EST
Description of problem:
After upgrading firefox to 1.5.0.8-1 on my x86_64 box, I get a seg fault when
starting firefox.

Note: I'm using the i386 firefox binary

[root@cookie ~]# uname -a
Linux cookie.localdomain 2.6.18-1.2849.fc6 #1 SMP Fri Nov 10 12:34:46 EST 2006
x86_64 x86_64 x86_64 GNU/Linux
[root@cookie ~]# rpm -q firefox
firefox-1.5.0.8-1.fc6.i386

Version-Release number of selected component (if applicable):
firefox-1.5.0.8-1.fc6.i386

How reproducible:
Always

Steps to Reproduce:
1. Start firefox
2.
3.
  
Actual results:

[lapham2@cookie ~]$ /usr/lib/firefox-1.5.0.8/firefox
/usr/lib/firefox-1.5.0.8/run-mozilla.sh: line 131:  6156 Segmentation fault    
 "$prog" ${1+"$@"}


Expected results:


Additional info:
Comment 1 Christopher Aillon 2006-11-14 02:03:03 EST
I wonder if this is the same as bug 214950 (caused by bug 214696).  Does
downgrading your at-spi help?
Comment 2 JLapham 2006-11-14 04:59:44 EST
I'm using:

[root@cookie ~]# rpm -q at-spi
at-spi-1.7.11-2.fc6.x86_64
at-spi-1.7.11-2.fc6.i386

...which is the version that was released with FC6, no updates.  So, what should
I downgrade to?  In bug 214696 the user was playing with FC7 Test,
at-spi-1.7.12-1.fc7 and downgraded to at-spi-1.7.11-2.fc6.i386.rpm (what I am
using).

So, I think it is not at-spi.  If you still suspect that it is, please let me
know what at-spi package to try to use for the downgrade.
Comment 3 Christopher Aillon 2006-11-14 09:22:42 EST
Okay probably not that then.  Can you try running the following (as root):

yum --enable-repo=updates-debuginfo install firefox-debuginfo glib2-debuginfo
pango-debuginfo gtk2-debuginfo

and then getting a gdb backtrace?  See http://fedoraproject.org/wiki/StackTraces
for how to do that.
Comment 4 JLapham 2006-11-14 20:55:27 EST
After applying today's round of updates, the problem has gone away.

If it would be helpful, I am willing to try to downgrade the packages one by one
to track down the problem more.  Anyway, the fix was in one of these updates:

Nov 14 12:55:43 Updated: nautilus-extensions.x86_64 2.16.2-5.fc6
Nov 14 12:55:58 Updated: foomatic.x86_64 3.0.2-39.1.fc6
Nov 14 12:56:14 Updated: libsoup.x86_64 2.2.97-1.fc6
Nov 14 12:56:15 Updated: nautilus-extensions.i386 2.16.2-5.fc6
Nov 14 12:56:22 Updated: libsoup.i386 2.2.97-1.fc6
Nov 14 12:56:41 Updated: nautilus.x86_64 2.16.2-5.fc6
Nov 14 12:56:44 Updated: gnome-python2-gnomevfs.x86_64 2.16.2-1.fc6
Nov 14 12:56:45 Updated: pygobject2.x86_64 2.12.2-2.fc6
Nov 14 12:56:45 Updated: gnome-python2-bonobo.x86_64 2.16.2-1.fc6
Nov 14 12:56:47 Updated: nfs-utils.x86_64 1:1.0.10-1.fc6
Nov 14 12:56:47 Updated: gnome-python2-gconf.x86_64 2.16.2-1.fc6
Nov 14 12:56:47 Updated: gnome-python2-canvas.x86_64 2.16.2-1.fc6
Nov 14 12:56:48 Updated: hal-cups-utils.x86_64 0.6.2-4.2
Nov 14 12:56:48 Updated: xorg-x11-xinit.x86_64 1.0.2-15.fc6
Nov 14 12:56:49 Updated: gnome-python2.x86_64 2.16.2-1.fc6

Note You need to log in before you can comment on or make changes to this bug.