Bug 215451 - Exception when installing IPv6 w/o IPv4
Exception when installing IPv6 w/o IPv4
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-13 20:55 EST by Stephanie J. Skaff
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-28 16:36:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fedore Core 6 updates.img for anaconda (1.41 MB, application/octet-stream)
2006-11-28 16:37 EST, David Cantrell
no flags Details

  None (edit)
Description Stephanie J. Skaff 2006-11-13 20:55:40 EST
Description of problem:
When installing FC6, Anaconda either fails (text) or refuses to allow (graphic)
when IPv6 is installed without IPv4.  (Same graphic install failure on ia64)


Version-Release number of selected component (if applicable):
anaconda shipped with FC6, i386

How reproducible:


Steps to Reproduce:
1.  Freshly install from CD/DVD using text installation
2.  At network configuration screen, deselect DHCP, IPv4,
    [activate on boot - same result either way]
3.
  
Actual results: 
[GRAPHIC INSTALL RESULTS]:
Error With Data window: The IPv4 information you have entered is invalid.


[TEXT INSTALL RESULTS]:
Exception occurred
Traceback (most recent call first):
  File
"/usr/lib/anaconda/textw/network_text.py",
line 400, in runScreen
     handleBroadcastError()
  File
"/usr/lib/anaconda/textw/network_text.py",
line 447, in __call__
     showonboot)
  File "/usr/lib/anaconda/text.py", line
517, in run
    rc = win(self.screen, instance)
  File "/usr/bin/anaconda", line 957, in ?
         anaconda.intf.run(anaconda)
TypeError: handleBroadCastError() takes
exactly 1 argument (0 given)

on OK, install exits abnormally [1/1]

Expected results:
Anaconda should continue running.

Additional info:
Comment 1 Stephanie J. Skaff 2006-11-13 20:56:56 EST
Ooops! How reproducible: always
Comment 2 David Cantrell 2006-11-28 16:36:10 EST
Apologies for taking so long.  I've fixed this problem in our rawhide
development tree for anaconda.  Since you need to do your work using FC-6, I've
created an updates.img file which you can use during the FC-6 installation to
get these fixes and install.

The updates.img file is attached to this bug report as FC6-updates.img.

For instructions on using updates.img, see this page:
http://fedoraproject.org/wiki/Anaconda/Updates
Comment 3 David Cantrell 2006-11-28 16:37:18 EST
Created attachment 142329 [details]
Fedore Core 6 updates.img for anaconda

Note You need to log in before you can comment on or make changes to this bug.