Bug 2154633 - python-socks-2.4.3 is available
Summary: python-socks-2.4.3 is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-socks
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ankur Sinha (FranciscoD)
QA Contact:
URL:
Whiteboard:
Depends On: 2238236 2241728
Blocks: 2140663
TreeView+ depends on / blocked
 
Reported: 2022-12-18 06:07 UTC by Upstream Release Monitoring
Modified: 2023-11-21 07:30 UTC (History)
1 user (show)

Fixed In Version: python-socks-2.4.3-1.fc40
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-11-21 07:30:37 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
Update to 2.1.1 (#2154633) (681 bytes, patch)
2022-12-19 12:12 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 2.3.0 (#2154633) (680 bytes, patch)
2023-05-08 07:15 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 2.4.0 (#2154633) (680 bytes, patch)
2023-09-08 07:32 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 2.4.1 (#2154633) (680 bytes, patch)
2023-09-08 09:50 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 2.4.3 (#2154633) (681 bytes, patch)
2023-09-26 09:03 UTC, Upstream Release Monitoring
no flags Details | Diff

Description Upstream Release Monitoring 2022-12-18 06:07:09 UTC
Releases retrieved: 2.1.0
Upstream release that is considered latest: 2.1.0
Current version/release in rawhide: 2.0.3-5.fc38
URL: https://pypi.org/project/python-socks/1.0.0

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/135744/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/python-socks

Comment 1 Upstream Release Monitoring 2022-12-18 06:07:14 UTC
Scratch build failed. Details below:

GenericError: File upload failed: cli-build/1671343632.5555637.nGdJpXoQ/python-socks-2.1.0-1.fc36.src.rpm
Traceback:
  File "/usr/local/lib/python3.10/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
  File "/usr/local/lib/python3.10/site-packages/hotness/builders/koji.py", line 198, in build
    output["build_id"] = self._scratch_build(session, package.name, srpm)
  File "/usr/local/lib/python3.10/site-packages/hotness/builders/koji.py", line 451, in _scratch_build
    session.uploadWrapper(source, serverdir)
  File "/usr/lib/python3.10/site-packages/koji/__init__.py", line 3083, in uploadWrapper
    self.fastUpload(localfile, path, name, callback, blocksize, overwrite, volume=volume)
  File "/usr/lib/python3.10/site-packages/koji/__init__.py", line 3018, in fastUpload
    raise GenericError("File upload failed: %s/%s" % (path, name))

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 2 Upstream Release Monitoring 2022-12-19 12:12:04 UTC
Releases retrieved: 2.1.1
Upstream release that is considered latest: 2.1.1
Current version/release in rawhide: 2.0.3-5.fc38
URL: https://pypi.org/project/python-socks/1.0.0

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/135744/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/python-socks

Comment 3 Upstream Release Monitoring 2022-12-19 12:12:08 UTC
Created attachment 1933601 [details]
Update to 2.1.1 (#2154633)

Comment 4 Upstream Release Monitoring 2022-12-19 12:17:40 UTC
the-new-hotness/release-monitoring.org's scratch build of python-socks-2.1.1-1.fc36.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=95535615

Comment 5 Upstream Release Monitoring 2023-03-13 07:53:38 UTC
Releases retrieved: 2.2.0
Upstream release that is considered latest: 2.2.0
Current version/release in rawhide: 2.0.3-6.fc38
URL: https://pypi.org/project/python-socks/1.0.0

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/135744/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/python-socks

Comment 6 Upstream Release Monitoring 2023-03-13 07:53:42 UTC
Scratch build failed. Details below:

GenericError: File upload failed: cli-build/1678694020.7503688.kekyXwLt/python-socks-2.2.0-1.fc36.src.rpm
Traceback:
  File "/usr/local/lib/python3.10/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
  File "/usr/local/lib/python3.10/site-packages/hotness/builders/koji.py", line 198, in build
    output["build_id"] = self._scratch_build(session, package.name, srpm)
  File "/usr/local/lib/python3.10/site-packages/hotness/builders/koji.py", line 451, in _scratch_build
    session.uploadWrapper(source, serverdir)
  File "/usr/lib/python3.10/site-packages/koji/__init__.py", line 3110, in uploadWrapper
    self.fastUpload(localfile, path, name, callback, blocksize, overwrite, volume=volume)
  File "/usr/lib/python3.10/site-packages/koji/__init__.py", line 3034, in fastUpload
    raise GenericError("File upload failed: %s/%s" % (path, name))

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 7 Upstream Release Monitoring 2023-05-08 07:15:45 UTC
Releases retrieved: 2.3.0
Upstream release that is considered latest: 2.3.0
Current version/release in rawhide: 2.0.3-6.fc38
URL: https://pypi.org/project/python-socks/1.0.0

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/135744/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/python-socks

Comment 8 Upstream Release Monitoring 2023-05-08 07:15:49 UTC
Scratch build failed. Details below:

BuilderException: Build failed:
Command '['rpmbuild', '-D', '_sourcedir .', '-D', '_topdir .', '-bs', '/var/tmp/thn-vzachosm/python-socks.spec']' returned non-zero exit status 1.

StdOut:
setting SOURCE_DATE_EPOCH=1683504000
error: Bad file: ./python-socks-2.3.0.tar.gz: No such file or directory

RPM build errors:
    Bad file: ./python-socks-2.3.0.tar.gz: No such file or directory


Traceback:
  File "/usr/local/lib/python3.11/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/local/lib/python3.11/site-packages/hotness/builders/koji.py", line 225, in build
    raise BuilderException(

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 9 Upstream Release Monitoring 2023-05-08 07:15:50 UTC
Created attachment 1963144 [details]
Update to 2.3.0 (#2154633)

Comment 10 Ankur Sinha (FranciscoD) 2023-07-29 14:55:24 UTC
Requires new packages:
No matching package to install: 'python3dist(tiny-proxy) >= 0.1.1

tiny-proxy requires:

- httpx-socks

this requires an update to python-httpcore. Opened a PR, waiting on maintainer.

Comment 11 Upstream Release Monitoring 2023-09-08 07:32:16 UTC
Releases retrieved: 2.4.0
Upstream release that is considered latest: 2.4.0
Current version/release in rawhide: 2.0.3-10.fc39
URL: https://pypi.org/project/python-socks/1.0.0

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/135744/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/python-socks

Comment 12 Upstream Release Monitoring 2023-09-08 07:32:19 UTC
Created attachment 1987679 [details]
Update to 2.4.0 (#2154633)

Comment 13 Upstream Release Monitoring 2023-09-08 07:37:43 UTC
the-new-hotness/release-monitoring.org's scratch build of python-socks-2.4.0-1.fc38.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=105895979

Comment 14 Upstream Release Monitoring 2023-09-08 09:50:48 UTC
Releases retrieved: 2.4.1
Upstream release that is considered latest: 2.4.1
Current version/release in rawhide: 2.0.3-10.fc39
URL: https://pypi.org/project/python-socks/1.0.0

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/135744/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/python-socks

Comment 15 Upstream Release Monitoring 2023-09-08 09:50:51 UTC
Created attachment 1987699 [details]
Update to 2.4.1 (#2154633)

Comment 16 Upstream Release Monitoring 2023-09-08 09:56:36 UTC
the-new-hotness/release-monitoring.org's scratch build of python-socks-2.4.1-1.fc38.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=105899114

Comment 17 Upstream Release Monitoring 2023-09-11 07:12:36 UTC
Releases retrieved: 2.4.2
Upstream release that is considered latest: 2.4.2
Current version/release in rawhide: 2.0.3-10.fc39
URL: https://pypi.org/project/python-socks/1.0.0

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/135744/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/python-socks

Comment 18 Upstream Release Monitoring 2023-09-11 07:12:40 UTC
Scratch build failed. Details below:

GSSAPIAuthError: unable to obtain a session (gssapi auth failed: requests.exceptions.HTTPError: 500 Server Error: Internal Server Error for url: https://koji.fedoraproject.org/kojihub/ssllogin)
Use following documentation to debug kerberos/gssapi auth issues. https://docs.pagure.org/koji/kerberos_gssapi_debug/
Traceback:
  File "/usr/local/lib/python3.11/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/local/lib/python3.11/site-packages/hotness/builders/koji.py", line 249, in build
    session = self._session_maker()
              ^^^^^^^^^^^^^^^^^^^^^
  File "/usr/local/lib/python3.11/site-packages/hotness/builders/koji.py", line 436, in _session_maker
    result = koji_session.gssapi_login(
             ^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/lib/python3.11/site-packages/koji/__init__.py", line 2669, in gssapi_login
    raise GSSAPIAuthError(err)

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 19 Upstream Release Monitoring 2023-09-26 09:03:11 UTC
Releases retrieved: 2.4.3
Upstream release that is considered latest: 2.4.3
Current version/release in rawhide: 2.0.3-10.fc39
URL: https://pypi.org/project/python-socks/1.0.0

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/135744/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/python-socks

Comment 20 Upstream Release Monitoring 2023-09-26 09:03:15 UTC
Created attachment 1990559 [details]
Update to 2.4.3 (#2154633)

Comment 21 Upstream Release Monitoring 2023-09-26 09:08:57 UTC
the-new-hotness/release-monitoring.org's scratch build of python-socks-2.4.3-1.fc38.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=106728393

Comment 22 Fedora Update System 2023-11-21 07:29:56 UTC
FEDORA-2023-8b197e4d37 has been submitted as an update to Fedora 40. https://bodhi.fedoraproject.org/updates/FEDORA-2023-8b197e4d37

Comment 23 Fedora Update System 2023-11-21 07:30:37 UTC
FEDORA-2023-8b197e4d37 has been pushed to the Fedora 40 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.