Bug 215476 - nfs-utils-1.0.10-1.fc6 breaks NFSv3 support
Summary: nfs-utils-1.0.10-1.fc6 breaks NFSv3 support
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: nfs-utils   
(Show other bugs)
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Steve Dickson
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
: 215754 216031 (view as bug list)
Depends On:
Blocks: 215843
TreeView+ depends on / blocked
 
Reported: 2006-11-14 09:27 UTC by Adrian Reber
Modified: 2007-11-30 22:11 UTC (History)
6 users (show)

Fixed In Version: nfs-utils-1.0.10-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-16 21:39:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Adrian Reber 2006-11-14 09:27:51 UTC
With the new update of nfs-utils-1.0.10-1.fc6 we cannot mount NFSv3 shares anymore:

# mount -t nfs rhns02:/vol/public/rz.coma /mnt/rz.coma -o
rw,nodev,nosuid,hard,intr,tcp,nfsvers=3,rsize=32768,wsize=32768
NFS version 3 is not supported.

Reverting back to the previous version fixes the problem for us:
# rpm -Uvh nfs-utils-1.0.9-8.fc6.i386.rpm --oldpackage

Comment 1 Steve Dickson 2006-11-14 12:56:29 UTC
Could you please post a bzip2 binary tethereal network trace
of this failure? Something similar to:
    tethereal -w /tmp/mount.pcap host <servername> ; bzip2 /tmp/mount.pcap

Also could you please added the -v mount option and post what
that output is as well....

Comment 2 dhawes 2006-11-14 13:03:23 UTC
I get this problem when trying to mount an nfs file server that ONLY supports
version 3 mounts and has version 2 exports disabled.

Copying back just '/sbin/mount.nfs' from the previous version of nfs-utils will
fix the problem.

Comment 3 Martin R. Schmid 2006-11-14 13:25:07 UTC
mounts using version 2 works - when using options as posted we can't capture any
packet.
The same with mount -v ... no additional output just: NFS version 3 is not
supported.
Should I send strace output?

Comment 4 Andrew Clayton 2006-11-15 13:10:18 UTC
Bingo!

Spent all morning trying to find out why our autofs mounts where no longer
mounting. Finally tracked it down to the nfs-utils update, searched bugzilla
found this entry and sure enough changing to vers=2 makes it work.


Comment 5 Andrew Clayton 2006-11-15 13:22:18 UTC
yeah, doesn't seem to get as far as generating any network traffic.

Comment 6 Andrew Clayton 2006-11-15 13:28:40 UTC
Using the mount.nfs binary from the previous package still works with the
updated nfs-utils package installed.

Whether that helps any...


Comment 7 Andrew Clayton 2006-11-15 13:33:08 UTC
Doh, just seen a previous comment saying that. 



Comment 8 Tomasz Kepczynski 2006-11-15 17:09:20 UTC
I think I have the same or very similar problem problem. In my case
new nfs-utils package breaks autofs but only for one autofs directory.
This directory is yp map:
geralt:~> ypcat -k auto.home
* -vers=3               triss.jot23.org:/nfs/home/&
What i get in logs (with debug logging) is:
Nov 15 17:45:37 geralt automount[4641]: master_do_mount: mounting /home
Nov 15 17:45:37 geralt automount[4641]: lookup_nss_read_map: reading map yp
auto.home
Nov 15 17:45:37 geralt automount[4641]: lookup_init: lookup(yp):
ctxt->mapname=auto.home
Nov 15 17:45:42 geralt automount[4641]: handle_packet: type = 3
Nov 15 17:45:42 geralt automount[4641]: handle_packet_missing_indirect: token
26, name tomek, request pid 4652
Nov 15 17:45:42 geralt automount[4641]: lookup_mount: lookup(yp): looking up tomek
Nov 15 17:45:42 geralt automount[4641]: lookup_mount: lookup(yp): tomek ->
-vers=3              triss.jot23.org:/nfs/home/&
Nov 15 17:45:42 geralt automount[4641]: parse_mount: parse(sun): expanded entry:
-vers=3                triss.jot23.org:/nfs/home/tomek
Nov 15 17:45:42 geralt automount[4641]: parse_mount: parse(sun): gathered
options: vers=3
Nov 15 17:45:42 geralt automount[4641]: parse_mount: parse(sun):
dequote("triss.jot23.org:/nfs/home/tomek") -> triss.jot23.org:/nfs/home/tomek
Nov 15 17:45:42 geralt automount[4641]: parse_mount: parse(sun): core of entry:
options=vers=3, loc=triss.jot23.org:/nfs/home/tomek
Nov 15 17:45:42 geralt automount[4641]: sun_mount: parse(sun): mounting root
/home, mountpoint tomek, what triss.jot23.org:/nfs/home/tomek, fstype nfs,
options vers=3
Nov 15 17:45:42 geralt automount[4641]: mount_mount: mount(nfs): root=/home
name=tomek what=triss.jot23.org:/nfs/home/tomek, fstype=nfs, options=vers=3
Nov 15 17:45:42 geralt automount[4641]: mount_mount: mount(nfs): nfs
options="vers=3", nosymlink=0, ro=0
Nov 15 17:45:42 geralt automount[4641]: mount_mount: mount(nfs): calling
mkdir_path /home/tomek
Nov 15 17:45:42 geralt automount[4641]: mount_mount: mount(nfs): calling mount
-t nfs -s -o vers=3 triss.jot23.org:/nfs/home/tomek /home/tomek
Nov 15 17:45:42 geralt automount[4641]: >> NFS version 3 is not supported.

nfs-utils-1.0.9-8.fc6.x86_64 works fine.
What is interestinf for new nfs-utils is that I can mount affected
directory by hand by command:
mount triss:/home/tomek /mnt
Please note - I haven't used vers option in the above command and
this probably is a culprit.
It looks like bug #215754 might describe the same problem as mine.

Comment 9 Steve Dickson 2006-11-15 18:57:13 UTC
I think I figured out what the problem is... The rpms in 
http://people.redhat.com/steved/bz212476 should hopefully solve
this problem... Please let me know... 



Comment 10 Steve Dickson 2006-11-15 18:58:51 UTC
*** Bug 215754 has been marked as a duplicate of this bug. ***

Comment 11 Andrew Clayton 2006-11-15 20:46:37 UTC
I think the url should be: http://people.redhat.com/steved/bz215476


Comment 12 Andrew Clayton 2006-11-15 20:58:53 UTC
Cool. Works for me.


Comment 13 Steve Dickson 2006-11-16 00:00:04 UTC
Andrew,

thank you for point that typo out... and I'm glad the new rpms are working...
I'll push the them out asaic... 


Comment 14 Steve Dickson 2006-11-16 21:39:57 UTC
Fixed in nfs-utils-1.0.10-3

Comment 15 Steve Dickson 2006-11-29 15:31:31 UTC
*** Bug 216031 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.