Bug 215482 - Exception trying to upgrade from RHEL4
Exception trying to upgrade from RHEL4
Status: CLOSED DUPLICATE of bug 213869
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-14 05:27 EST by Bastien Nocera
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-14 05:51:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.patch (653 bytes, patch)
2006-11-14 05:27 EST, Bastien Nocera
no flags Details | Diff

  None (edit)
Description Bastien Nocera 2006-11-14 05:27:44 EST
Problem looks like it's still in the HEAD of the rhel5-branch branch

1. install RHEL4 U4
2. Boot the system with netboot image of RHEL5 beta1 1027 build
3. select NFS install method, config network and provide NFS server info
4. in "System to Upgrade" screen, select "Red Hat Enterprise Linux AS 4
(/dev/VolGroup00/LogVol00)" and press OK

Screescraped traceback:

File "/usr/lib/anaconda/textw/upgrade_text.py", line 228, in __call__          
             
 c.installkey = self.anaconda.id.instClass.installkey
File "/usr/lib/anaconda/text.py", line 561, in run                                  
 rc = win(self.screen, instance)
File "/usr/bin/anaconda", line 967, in anaconda.intf.run(anaconda)             
 AttributeError: UpgradeExamineWindow instance has no attribute 'anaconda'         

Patch from ddearauj@us.ibm.com
Comment 1 Bastien Nocera 2006-11-14 05:27:45 EST
Created attachment 141144 [details]
anaconda.patch
Comment 2 RHEL Product and Program Management 2006-11-14 05:40:25 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Paul Nasrat 2006-11-14 05:51:09 EST
brew latest-pkg --quiet RHEL-5-Beta-2 anaconda
anaconda-11.1.2.16-1                      RHEL-5-Beta-2         pnasrat


*** This bug has been marked as a duplicate of 213869 ***

Note You need to log in before you can comment on or make changes to this bug.