Bug 215485 - rpc.statd doesn't seem to have tcp_wrapper support as detailed in man page
rpc.statd doesn't seem to have tcp_wrapper support as detailed in man page
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: nfs-utils (Show other bugs)
3.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Steve Dickson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-14 06:10 EST by Matt Ford
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 14:40:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Ford 2006-11-14 06:10:10 EST
Description of problem:

rpc.statd and tcp_wrappers support.  The man page says that rpc.statd is
compiled with tcp_wrapper support but looking at the source rpm it doesn't look
like it is - there's a change log dated 2000 saying tcp_wrapper support was
disabled.

Running

strings -f `which rpc.statd` | grep "wrap"
strings -f `which rpc.statd` | grep "host"

doesn't show any sign that tcp_wrappers support is compiled in.

My questions is; is it supported?  Is this deliberate and what was the reason if so?

Cheers,

Matt.

RHE3, Fedora Core 6

How reproducible:

Expected results:

TCP Wrapper support compiled in.
Comment 1 Matt Ford 2006-11-14 07:02:45 EST
I have further tested this between systems: rpc.statd does not use tcp_wrappers
as described in the man page.  Further, portmap does not respect the
tcp_wrappers configuration file fully - even when configured not to allow local
connections to the portmapper it still does.  

Expected result:

portmap should obey tcp_wrapper deny all directive.
Comment 2 RHEL Product and Program Management 2007-10-19 14:40:00 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.