Bug 215641 - Patch to fix reset issue when ethernet interface is enabled.
Patch to fix reset issue when ethernet interface is enabled.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike Christie
Brian Brock
:
: 215028 (view as bug list)
Depends On:
Blocks: 213807 216985
  Show dependency treegraph
 
Reported: 2006-11-14 18:24 EST by David Somayajulu
Modified: 2007-11-30 17:07 EST (History)
8 users (show)

See Also:
Fixed In Version: RC
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-07 19:28:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix reset issue when ethernet interface is enabled. (6.19 KB, patch)
2006-11-14 18:24 EST, David Somayajulu
no flags Details | Diff
Regenerated patch against root of kernel source tree (6.68 KB, patch)
2006-12-01 22:29 EST, David Somayajulu
no flags Details | Diff

  None (edit)
Description David Somayajulu 2006-11-14 18:24:15 EST
Description of problem:
Each port on qla4xxx has two MACs, one is used for Ethernet Network Interface 
(supported by qla3xxx) and the other used of iSCSI. The above interfaces are 
supported as a single chip solution. The problem happens when both qla3xxx and 
qla4xxx drivers are loaded. The issue happens when the iSCSI Interface issues 
a reset in response to a Network Reset without first grabbing the Qla4xxx 
Hardware semaphore.

Version-Release number of selected component (if applicable):


How reproducible:
Load the qla3xxx driver with qla4xxx already loaded.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Networking halts.

Expected results:
Both network and iSCSI interfaces should exist happily.

Additional info:
In addition the enclosed patch gets rid of support for a version of qla4xxx 
called TOPCAT which never shipped and will never ship.
Comment 1 David Somayajulu 2006-11-14 18:24:16 EST
Created attachment 141199 [details]
patch to fix reset issue when ethernet interface is enabled.
Comment 3 RHEL Product and Program Management 2006-11-30 15:32:26 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 David Somayajulu 2006-12-01 22:29:36 EST
Created attachment 142649 [details]
Regenerated patch against root of kernel source tree

Regenerated patch against root of kernel source tree
Comment 5 Konrad Rzeszutek 2006-12-04 11:07:14 EST
Mike or Doug,

Have you had a chance to test this patch?
Comment 6 Konrad Rzeszutek 2006-12-04 11:57:00 EST
Mike,
From another BZ (which is a dup of this one), Doug confirms testing this this
patch with success.

------- Additional Comments From tao@redhat.com  2006-12-04 11:33 EST -------
Update to issue 106549 by bugzilla
> Action: These changes made by konradr@redhat.com.
> Bugzilla comment added:
>  Doug,
>
> Please confirm that the patch mentioned in Red Hat BZ 215641 which was
> posted by
>   David Somayajulu fixes hits BZ as well?
>
>
> https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=215028

Yes, the patch in RHBZ 215641 appears to correct this issue.  The patch
was
applied to the -2747 kernel and has been tested on JS20 and POWER5.
Comment 7 Mike Christie 2006-12-04 13:13:10 EST
Thanks Konrad.
Comment 8 Jay Turner 2006-12-04 20:16:29 EST
QE ack for RHEL5.  Setting blocker, otherwise the issue won't get picked up for
RHEL5.  This is a bug in new hardware support.
Comment 9 Konrad Rzeszutek 2006-12-14 13:07:02 EST
Mike,

Has this patch been posted for inclusion in RHEL5?
Comment 12 Konrad Rzeszutek 2006-12-19 10:48:02 EST
Mike,

Any outlook with having this BZ? Is the patch for this problem already posted on
RHKL?
Comment 14 Andrius Benokraitis 2007-01-05 15:27:26 EST
*** Bug 215028 has been marked as a duplicate of this bug. ***
Comment 15 Konrad Rzeszutek 2007-01-09 10:55:42 EST
Mike,

I am looking in the RHKL for this patch and I cannot find it? Can you provide
the URL or the date when you posted this patch?

Thanks.
Comment 16 Janice Girouard - IBM on-site partner 2007-01-09 11:14:47 EST
kernel-2.6.18-1.2987.el5.src.rpm contains the first patch:

patch to fix reset issue when ethernet interface is enabled.   	 Valid  	
patch   	2006-11-14 18:24 EST  	6.19 KB  	 Edit  | Diff
which is shown at:
https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=141199
Comment 17 Mike Christie 2007-01-09 12:11:56 EST
Konrad, do you still need a link or something? All the patches that were listed
in the 4032 support bugzilla
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=213807 in comment #20 were
rolled up into a one large patch and merged last week.
Comment 18 Tom Coughlan 2007-01-11 10:20:01 EST
Comment 17 says this went in as part of the 213807 fix. That BZ is MODIFIED, so
I am setting this likewise. 
Comment 19 RHEL Product and Program Management 2007-02-07 19:28:38 EST
A package has been built which should help the problem described in 
this bug report. This report is therefore being closed with a resolution 
of CURRENTRELEASE. You may reopen this bug report if the solution does 
not work for you.

Note You need to log in before you can comment on or make changes to this bug.