Bug 215655 - php-xml should provide php-domxml
php-xml should provide php-domxml
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: php (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
: 215656 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-14 20:45 EST by Greg Swallow
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: 5.1.6-4.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-22 09:53:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Swallow 2006-11-14 20:45:27 EST
Description of problem:
php-xml should provide php-domxml - it obsoletes it, but doesn't provide it.  
For the benefit of a smooth upgrade from RHEL4 to RHEL5 where additional 
applications (rpms) have been installed that require php-domxml, this fix would 
be needed.  

Version-Release number of selected component (if applicable):
5.1.4-8.1

How reproducible:
always

Steps to Reproduce:
1.look at the spec file
2.
3.
  
Actual results:
%package xml
Summary: A module for PHP applications which use XML
Group: Development/Languages
Requires: php = %{version}-%{release}
Obsoletes: php-domxml, php-dom
Provides: php-dom, php-xsl


Expected results:
%package xml
Summary: A module for PHP applications which use XML
Group: Development/Languages
Requires: php = %{version}-%{release}
Obsoletes: php-domxml, php-dom
Provides: php-dom, php-xsl, php-domxml

Additional info:
Comment 1 Joe Orton 2006-11-15 06:17:02 EST
*** Bug 215656 has been marked as a duplicate of this bug. ***
Comment 2 Johnny Hughes 2006-11-15 06:37:50 EST
I agree that this seems the only clean way to use if a package can work with
either php-4 or php-5 ... and it also provides direct upgrade capability from
php-4 to php-5.
Comment 3 Greg Swallow 2006-11-15 14:41:15 EST
The comment I made here regarding the horde rpm 
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=189195#c17 is an example 
of why this would be nice if it was fixed.
Comment 4 Greg Swallow 2006-11-15 15:07:56 EST
I cloned this bug to Fedora Rawhide - bug 215799
Comment 5 Greg Swallow 2006-11-21 13:59:24 EST
Bumping to RHEL5-Beta2 with php-5.1.6-3 - same thing
Comment 6 Joe Orton 2006-12-01 04:18:49 EST
Fixed in 5.1.6-4.el5, thanks for the report.

Note You need to log in before you can comment on or make changes to this bug.