Bug 215742 - seobject.py has a translation bug
seobject.py has a translation bug
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: policycoreutils (Show other bugs)
6
All Linux
medium Severity low
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-15 10:46 EST by Eric Preston
Modified: 2009-09-21 17:17 EDT (History)
1 user (show)

See Also:
Fixed In Version: Current
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-21 10:42:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Preston 2006-11-15 10:46:34 EST
Description of problem:

Sitting in RHS429 this week a student noticed a but with MLS/MCS
translation with an example under FC6 and I tracked it down.

How reproducible:

Garranteed

Steps to Reproduce:
1. semanage translation -a -T Hipaa s0:c1
2. semanage login -l
3. Note that Hipaa seems truncated
  
Actual results:

Hip

Expected results:

Hipaa

Additional info:

seobject.py contains a bug in which string.strip("a:b:c") 
does not do what the author intended.

both

def translate(raw, prepend = 1):
   ...
   trans = trans.strip("a:b:c") ---> [Line 105]

and

def untranslate(trans, prepend = 1):
   ...
   raw = raw.strip("a:b:c") ---> [line 121?]

is not doing what is intended.

Cheers,
Eric
Comment 1 Daniel Walsh 2007-02-14 16:32:03 EST
Fixed in policycoreutils-1.34.1-4.fc6

Note You need to log in before you can comment on or make changes to this bug.