Bug 215765 - DHCP failure with tg3 (BCM5752M)
DHCP failure with tg3 (BCM5752M)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Andy Gospodarek
Brian Brock
:
: 213144 (view as bug list)
Depends On:
Blocks: 221460
  Show dependency treegraph
 
Reported: 2006-11-15 12:09 EST by Chris Lalancette
Modified: 2014-06-29 18:58 EDT (History)
6 users (show)

See Also:
Fixed In Version: beta2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-22 21:45:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
upstream.patch (526 bytes, patch)
2006-11-17 14:23 EST, Andy Gospodarek
no flags Details | Diff

  None (edit)
Description Chris Lalancette 2006-11-15 12:09:50 EST
Description of problem:
I just got a shiny new laptop, a Lenovo z61t.  After a couple of failures in
unrelated components, I have narrowed my current problem:

1.  Boot the kernel in single user mode (2.6.18-1.2747.el5)
2.  Start the network (service network start); at this point, the machine will
bring up the tg3 as eth0, DHCP, and get an address.  All is well.
3.  Restart the network (service network restart); at this point, the machine
will try to DHCP again, but will fail to get an address.

The tg3 card in question is:

02:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5752M Gigabit
Ethernet PCI Express (rev 02)

I've tried rmmod'ing and modprobe'ing the driver to reset it, to no avail.  I
also tried manually setting an IP address to the interface (ifconfig eth0 <ip>
netmask <netmask>), which also fails.  It seems that once it DHCP's a first
time, it can never be brought down, or it will fail.  This wouldn't seem that
important, except that the ability to re-DHCP is required for Xen to function
properly.
Comment 1 Andy Gospodarek 2006-11-17 14:23:44 EST
Created attachment 141520 [details]
upstream.patch

Chris, try this patch.	It looks like this was already fixed upstream in
2.6.19.
Comment 3 Chris Lalancette 2006-11-17 14:52:13 EST
Dude, you rock :).  Works like a champ now.  Thanks!
Comment 5 RHEL Product and Program Management 2006-11-17 15:21:17 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 9 Andy Gospodarek 2006-11-30 13:22:16 EST
*** Bug 213144 has been marked as a duplicate of this bug. ***
Comment 10 Jay Turner 2006-11-30 13:37:46 EST
QE ack for RHEL5.
Comment 13 Don Zickus 2006-12-05 14:50:08 EST
in 2.6.18-1.2817.el5
Comment 14 Andy Gospodarek 2006-12-06 09:59:12 EST
That means its also in my rhel5 test kernels here:

http://people.redhat.com/agospoda/#rhel5
Comment 15 RHEL Product and Program Management 2006-12-22 21:45:43 EST
A package has been built which should help the problem described in 
this bug report. This report is therefore being closed with a resolution 
of CURRENTRELEASE. You may reopen this bug report if the solution does 
not work for you.

Note You need to log in before you can comment on or make changes to this bug.