Bug 215784 - RHEL5 equivalent of the RHEL4 App Whitepaper
RHEL5 equivalent of the RHEL4 App Whitepaper
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: Documentation (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Riek
: Documentation, Reopened
: 184758 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-15 13:51 EST by Larry Troan
Modified: 2016-04-18 05:46 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 16:38:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Larry Troan 2006-11-15 13:51:49 EST
Need a RHEL5 white paper equivalent to the RHEL4 paper
http://www.redhat.com/f/pdf/rhel4/AppCompat.pdf 
written by Donald Fischer.

When is such a paper planned for distribution?
Comment 2 Larry Troan 2006-12-06 14:18:39 EST
Ping. 
-----
Any progress on this "Application Compatibility" white paper? 
Do we plan to do a RHEL5 edition/update of the RHEL4 work referenced above? 
Do we have an availability date?
Comment 3 Amit Bhutani 2006-12-07 01:56:58 EST
We were told in today's RH Engineering call that the App document from comment
#1 intended for RHEL4 is to remain unchanged for RHEL5. That contradicts what we
heard from another source which was RH intends to update it's core set of
libraries for which it will maintain ABI and API across major releases of the
ditribution. In particular I recall libgcj being mentioned as a new addition. Is
that not true ??
Comment 4 Daniel Riek 2006-12-20 23:59:04 EST
I do not understand comment #3. Citing from that dokument:
Red Hat provides compatibility libraries for a set of core libraries.  However,
Red Hat does not guarantee compatibility across major releases of the
distribution for dynamically linked libraries outside of the core library set unless
versions of the Dynamic Shared Objects (DSOs) the application expects are
provided (either as part of the application package or separate downloads).

RHEL5 will continue to provide that level of compatibility for X-2 major
releases (so RHEL3 and RHEL4). Actually we even extended that and provided
backwards compatibility for packages important for our partners if they were
reported in time.

So what is being asked for here?
Comment 5 Suzanne Yeghiayan 2007-01-12 15:01:29 EST
*** Bug 184758 has been marked as a duplicate of this bug. ***
Comment 6 Amit Bhutani 2007-01-14 11:31:33 EST
What is being requested here is the document that clearly outlines the core set
of libraries in RHEL5 that will be supported in X-2.
Comment 7 Larry Troan 2007-01-14 13:57:34 EST
Daniel, any estimate of when this will be available?
Comment 8 Ken Reilly 2007-01-17 17:26:27 EST
Given Daniel plans to post this document on the website, I cleared the blocker
flag. 
Comment 10 Amit Bhutani 2007-02-07 11:32:05 EST
Daniel- When are we going to see this document ?
Comment 11 Daniel Riek 2007-02-09 15:40:41 EST
This is not going to be shipped as part of the distribution. The Whitepaper is
committed for GA. 
Comment 12 Amit Bhutani 2007-02-09 19:05:17 EST
Well, we need *a* way to track this. I am re-opening the bug, changing component
to "Documentation". Please advice if you have a alternative suggestion to track
this.
Comment 15 Larry Troan 2007-05-31 08:59:09 EDT
Daniel, any idea when you will be able to share a draft with Dell?
Comment 17 John Feeney 2008-12-01 16:31:40 EST
Although it was a good idea that could not come to fruition, RHEL5 has 
survived for two years without this paper. Can this bz be closed now as
WontFix? 

Just doing some housekeeping.

Note You need to log in before you can comment on or make changes to this bug.