Bug 215799 - php-xml should provide php-domxml
php-xml should provide php-domxml
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-15 15:00 EST by Greg Swallow
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-16 18:55:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Swallow 2006-11-15 15:00:50 EST
Cloning this bug to Fedora Rawhide, as you'd probably like to fix it here 
first.  The same fix is required.  Thanks.

+++ This bug was initially created as a clone of Bug #215655 +++

Description of problem:
php-xml should provide php-domxml - it obsoletes it, but doesn't provide it.  
For the benefit of a smooth upgrade from RHEL4 to RHEL5 where additional 
applications (rpms) have been installed that require php-domxml, this fix would 
be needed.  

Version-Release number of selected component (if applicable):
5.1.4-8.1

How reproducible:
always

Steps to Reproduce:
1.look at the spec file
2.
3.
  
Actual results:
%package xml
Summary: A module for PHP applications which use XML
Group: Development/Languages
Requires: php = %{version}-%{release}
Obsoletes: php-domxml, php-dom
Provides: php-dom, php-xsl


Expected results:
%package xml
Summary: A module for PHP applications which use XML
Group: Development/Languages
Requires: php = %{version}-%{release}
Obsoletes: php-domxml, php-dom
Provides: php-dom, php-xsl, php-domxml

Additional info:

-- Additional comment from jorton@redhat.com on 2006-11-15 06:17 EST --
*** Bug 215656 has been marked as a duplicate of this bug. ***

-- Additional comment from johnny@centos.org on 2006-11-15 06:37 EST --
I agree that this seems the only clean way to use if a package can work with
either php-4 or php-5 ... and it also provides direct upgrade capability from
php-4 to php-5.

-- Additional comment from greg@runlevel7.ca on 2006-11-15 14:41 EST --
The comment I made here regarding the horde rpm 
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=189195#c17 is an example 
of why this would be nice if it was fixed.
Comment 1 Greg Swallow 2006-11-15 15:05:17 EST
Just for reference, the latest version at the moment is 5.1.6-4 and php-xml 
does not provide php-domxml.
Comment 2 Greg Swallow 2006-11-16 18:55:28 EST
This is fixed in 5.2.0-3

* Wed Nov 15 2006 Joe Orton <jorton@redhat.com> 5.2.0-3
- update to 5.2.0 (#213837)
- php-xml provides php-domxml (#215656)


Should be #215799, not 215656 by the way.  Thanks.  Will you clone this I guess 
to FC5 and/or FC6 if you think it's worth fixing there as well?  I am more 
interested in bug 215655 for RHEL5...

Note You need to log in before you can comment on or make changes to this bug.