Bug 215811 - yum-utils - a tracebac from package-cleanup
yum-utils - a tracebac from package-cleanup
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-15 16:20 EST by Michal Jaegermann
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-11 14:51:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2006-11-15 16:20:05 EST
Description of problem:

# package-cleanup --problems
Setting up yum
Reading local RPM database
Processing all local requires
Traceback (most recent call last):
  File "/usr/bin/package-cleanup", line 349, in ?
    main()
  File "/usr/bin/package-cleanup", line 346, in main
    provsomething = buildProviderList(my,pkgs,opts.problems)
  File "/usr/bin/package-cleanup", line 85, in buildProviderList
    resolve_sack = my.rpmdb.whatProvides(req,rflags,ver)
  File "/usr/lib/python2.4/site-packages/yum/rpmsack.py", line 364, in whatProvides
    morepkgs = self.searchFiles(name)
  File "/usr/lib/python2.4/site-packages/yum/rpmsack.py", line 103, in searchFiles
    if not result.has_key(pkg.pkgid):
TypeError: list objects are unhashable

Operations like --leaves, --orphans, or --dupes are fine.

Version-Release number of selected component (if applicable):
yum-utils-1.0.1-1.fc6

How reproducible:
always
Comment 1 Seth Vidal 2006-11-16 00:26:39 EST
When yum 3.0.1 comes out in updates. Please install it then retest this command.

thanks
 
Comment 2 Michal Jaegermann 2006-11-16 18:56:57 EST
After an update to yum-3.0.1-2.fc6, but with the same yum-utils package,
line numbers are slightly different but still a traceback.

# package-cleanup --problems
Setting up yum
Reading local RPM database
Processing all local requires
Traceback (most recent call last):
  File "/usr/bin/package-cleanup", line 349, in ?
    main()
  File "/usr/bin/package-cleanup", line 346, in main
    provsomething = buildProviderList(my,pkgs,opts.problems)
  File "/usr/bin/package-cleanup", line 85, in buildProviderList
    resolve_sack = my.rpmdb.whatProvides(req,rflags,ver)
  File "/usr/lib/python2.4/site-packages/yum/rpmsack.py", line 397, in whatProvides
    morepkgs = self.searchFiles(name)
  File "/usr/lib/python2.4/site-packages/yum/rpmsack.py", line 104, in searchFiles
    if not result.has_key(pkg.pkgid):
TypeError: list objects are unhashable
Comment 3 Seth Vidal 2006-12-11 14:51:35 EST
I'm pretty sure this is about the ListPackageSack issue in 3.0.1. It's fixed in
cvs now and should be set for 3.0.2.

Note You need to log in before you can comment on or make changes to this bug.