Bug 215908 - libica for s390 not installed but libica-devel is
libica for s390 not installed but libica-devel is
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: libica (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-16 05:45 EST by Bastien Nocera
Modified: 2015-03-04 20:17 EST (History)
4 users (show)

See Also:
Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-11 09:58:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bastien Nocera 2006-11-16 05:45:04 EST
1. Install RHEL5 Beta M9 on a zSeries machine
2. After installation, only the libica-devel is installed for s390:
libica-1.3.7-4.s390x
libica-devel-1.3.7-4.s390x
libica-devel-1.3.7-4.s390

libica-devel has a dep on libica. Could it be anaconda not taking the arch into
consideration for the dependency resolution?
Comment 1 RHEL Product and Program Management 2006-11-16 06:00:21 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 2 Dennis Gregorovic 2006-11-21 16:33:46 EST
RPM dependences do not have architecture information explicitly in them.  If the
32-bit libica-devel package required "libica.so" then it would pull in the
32-bit libica package since the 64-bit libica package doesn't provide that. 
However, as is, the 64-bit libica package meets the requirements of the 32-bit
libica-devel package.

# rpm -qRp s390/libica-devel-1.3.7-4.s390.rpm | grep -v rpmlib
libica = 1.3.7-4
zlib-devel
# rpm -qRp s390x/libica-devel-1.3.7-4.s390x.rpm | grep -v rpmlib
libica = 1.3.7-4
zlib-devel
# rpm -q --provides -p s390/libica-1.3.7-4.s390.rpm
libica.so
libica = 1.3.7-4
# rpm -q --provides -p s390x/libica-1.3.7-4.s390x.rpm 
libica.so()(64bit)
libica = 1.3.7-4
Comment 4 Dennis Gregorovic 2006-11-22 11:52:40 EST
Reassigning to the libica component as a fix will require a change to the packaging.
Comment 8 Jay Turner 2006-11-27 10:44:07 EST
QE ack for RHEL5.

Note You need to log in before you can comment on or make changes to this bug.