This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 215933 - segfault in the cups print backend [NEEDINFO]
segfault in the cups print backend
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gtksourceview (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
desktop-bugs@redhat.com
: Desktop, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-16 08:06 EST by Matthias Clasen
Modified: 2014-06-02 09:17 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:17:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
pm-rhel: needinfo? (mclasen)


Attachments (Terms of Use)

  None (edit)
Description Matthias Clasen 2006-11-16 08:06:17 EST
Under certain circumstances, the gtk cups print backend passes NULL to strncpy.
This was reported upstream as http://bugzilla.gnome.org/show_bug.cgi?id=359537
Comment 1 Matthias Clasen 2006-11-16 08:12:15 EST
Fixed in gtk2-2.10.4-5.el5
Comment 2 RHEL Product and Program Management 2006-11-16 08:20:32 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Xiaohong Wang 2007-01-02 01:24:19 EST
Did following testing in RHEL5-Client-20061226.nightly with gtk2-2.10.4-14.el5

test1:
1. run gedit in g-t
2. in gedit, select File -> Print (Print window pops up)
3. select "Create a PDF document" in "Printer" tab
4. Custom Paper size to be 8x6 in "Paper" tab
5. click "Print"
result: no PDF document created and in g-t, there is error message
----
(gedit:4997): GtkSourceView-CRITICAL **: update_page_size_and_margins: assertion
`job->priv->text_width > CM(5.0)' failed

** (gedit:4997): WARNING **: Async print preview failed
----

test2:
1. run gedit in g-t
2. in gedit, select File -> Print (Print window pops up)
3. Custom Paper size to be 8x6 in "Paper" tab
4. select "Create a PDF document" in "Printer" tab
5. click "Print"
result: a PDF document was created successuflly, but it is not the custom size
in page.

Comment 6 Matthias Clasen 2007-01-02 11:59:24 EST
No.

The testing did not at all test the fix in this bug, since gedit does not even
use the gtk print support yet. 

The testing did reveal some bugs in the gedit print support, but they need to be
filed against gedit (the async preview failure) and gtksourceview (the
update_page_size_and_margins assertion). I don't think they qualify as blockers
at this point.

The async preview failure has a simple workaround: select a real printer in the
print dialog, then the preview works.

The failure to create a document with the proper dimensions, I could not
reproduce that here. C5/C6 and some other paper sizes worked fine here, and
I don't have 8x6 in my list of paper sizes...
Comment 9 RHEL Product and Program Management 2007-06-05 16:50:27 EDT
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Since this
bugzilla is in a component that is not approved for the current
release, it has been closed with resolution deferred.  You may
reopen this bugzilla for consideration in the next release.
Comment 12 Ray Strode [halfline] 2007-12-18 17:28:45 EST
The problem seems to be that:

- the default units is centimeters
- 8x6 centimeters is too small for gtksourceview

we should just clamp the values in the dialog to the gtksourceview minimums i guess
Comment 13 Ray Strode [halfline] 2007-12-19 11:47:49 EST
or rather remove the limits, they're arbitrary
Comment 15 RHEL Product and Program Management 2014-03-07 08:42:43 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 16 RHEL Product and Program Management 2014-06-02 09:17:17 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.