Bug 215970 - kdeedu.i386 missing dependency on libpython2.4.so.1.0 on x86_64
kdeedu.i386 missing dependency on libpython2.4.so.1.0 on x86_64
Status: CLOSED DUPLICATE of bug 213505
Product: Fedora
Classification: Fedora
Component: kdeedu (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-16 12:09 EST by Paul Howarth
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-17 07:21:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Howarth 2006-11-16 12:09:17 EST
FC6 x86_64 box with updates repo enabled, kdeedu not installed:

# yum install kdeedu
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package kdeedu.x86_64 0:3.5.5-0.1.fc6 set to be updated
---> Package kdeedu.i386 0:3.5.5-0.1.fc6 set to be updated
--> Running transaction check
--> Processing Dependency: libpython2.4.so.1.0 for package: kdeedu
--> Processing Dependency: libDCOP.so.4 for package: kdeedu
--> Processing Dependency: libkhtml.so.4 for package: kdeedu
--> Processing Dependency: libkio.so.4 for package: kdeedu
--> Processing Dependency: libkdeprint.so.4 for package: kdeedu
--> Processing Dependency: libktexteditor.so.0 for package: kdeedu
--> Processing Dependency: libkdeui.so.4 for package: kdeedu
--> Processing Dependency: libboost_python.so.2 for package: kdeedu
--> Processing Dependency: libqt-mt.so.3 for package: kdeedu
--> Processing Dependency: libkdefx.so.4 for package: kdeedu
--> Processing Dependency: libknewstuff.so.1 for package: kdeedu
--> Processing Dependency: libartskde.so.1 for package: kdeedu
--> Processing Dependency: libkdecore.so.4 for package: kdeedu
--> Processing Dependency: libkparts.so.2 for package: kdeedu
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package boost.i386 0:1.33.1-6.1 set to be updated
---> Package qt.i386 1:3.3.7-0.1.fc6 set to be updated
---> Package kdelibs.i386 6:3.5.5-0.2.fc6 set to be updated
--> Running transaction check
--> Processing Dependency: libpython2.4.so.1.0 for package: kdeedu
--> Processing Dependency: libartsflow.so.1 for package: kdelibs
--> Processing Dependency: libpcre.so.0 for package: kdelibs
--> Processing Dependency: libkmedia2_idl.so.1 for package: kdelibs
--> Processing Dependency: libqtmcop.so.1 for package: kdelibs
--> Processing Dependency: libartsflow_idl.so.1 for package: kdelibs
--> Processing Dependency: libsoundserver_idl.so.1 for package: kdelibs
--> Processing Dependency: libmng.so.1 for package: qt
--> Processing Dependency: libmcop.so.1 for package: kdelibs
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package arts.i386 8:1.5.5-0.1.fc6 set to be updated
---> Package pcre.i386 0:6.6-1.1 set to be updated
---> Package libmng.i386 0:1.0.9-5.1 set to be updated
--> Running transaction check
--> Processing Dependency: libpython2.4.so.1.0 for package: kdeedu
--> Processing Dependency: libvorbis.so.0 for package: arts
--> Processing Dependency: libvorbisfile.so.3 for package: arts
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package libvorbis.i386 1:1.1.2-1.2.1 set to be updated
--> Running transaction check
--> Processing Dependency: libpython2.4.so.1.0 for package: kdeedu
--> Processing Dependency: libogg.so.0 for package: libvorbis
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package libogg.i386 2:1.1.3-2.fc6 set to be updated
--> Running transaction check
--> Processing Dependency: libpython2.4.so.1.0 for package: kdeedu
--> Finished Dependency Resolution
Error: Missing Dependency: libpython2.4.so.1.0 is needed by package kdeedu

kdeedu.i386 is not included in the base distribution, only in updates,
Comment 1 Rex Dieter 2006-11-16 14:46:11 EST
imo, python.i386 is the thing missing here for multilib, so it's not kdeedu's
problem, unless I'm misunderstanding something?
Comment 2 Paul Howarth 2006-11-16 15:37:33 EST
Yes, that would fix this problem, though I'm curious as to why kdeedu.i386
wasn't in the core x86_64 repo, just the updates repo - is it fixing some other
broken dependency? Is there a procedure in place for checking for newly-required
multilib packages that caused kdeedu.i386 to be pulled in, and if so, why wasn't
python.i386 also pulled in? On the other hand, perhaps the inclusion of
kdeedu.i386 was an error; I don't know.

Without knowing the procedure, it's hard to know the right component to use.
Comment 3 Ngo Than 2006-11-17 07:21:38 EST

*** This bug has been marked as a duplicate of 213505 ***
Comment 4 Philip Spencer 2006-12-14 15:46:08 EST
This is not a duplicate of 213505. Rather, the FIX for 213505 is what CAUSED
this bug.

To fix 213505, kdeedu.i386 was added to the x86_64 updates directory when it
wasn't previously present in the x86_64 base distribution.

However, kdeedu.i386 depends on python.i386 (by requiring the 32-bit
libpython2.4.so.1.0), and python.i386 is not included in either the base
distribution or updates directories for x86_64. Hence this bug.

Fixing this will require either (1) fixing 213505 in some way that does not
require the inclusion of kdeedu.i386 in the x86_64 updates directory, or (2)
adding python.i386 to the x86_64 updates directory, or (3) eliminating the
kdeedu->python dependency somehow.

Note You need to log in before you can comment on or make changes to this bug.