Bug 215979 - Nautilus crashes when I try to view bluetooth devices.
Nautilus crashes when I try to view bluetooth devices.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-16 12:43 EST by Alexey Titov
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 2.16.2-5.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-17 12:45:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexey Titov 2006-11-16 12:43:01 EST
Nautilus crashes every time when I type "bluetooth://" in address bar...
Here is BugBuddy report.

Distribution: Fedora Core release 6 (Zod)
Gnome Release: 2.16.0 2006-09-04 (Red Hat, Inc)
BugBuddy Version: 2.16.0

Memory status: size: 85864448 vsize: 0 resident: 85864448 share: 0 rss: 31592448
rss_rlim: 0
CPU usage: start_time: 1163698398 rtime: 0 utime: 238 stime: 0 cutime:220
cstime: 0 timeout: 18 it_real_value: 0 frequency: 0

Backtrace was generated from '/usr/bin/nautilus'

(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1208161536 (LWP 9105)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
0x00a0e402 in __kernel_vsyscall ()
#0  0x00a0e402 in __kernel_vsyscall ()
#1  0x00601cbb in __waitpid_nocancel () from /lib/libpthread.so.0
#2  0x04dbccf6 in gnome_gtk_module_info_get () from /usr/lib/libgnomeui-2.so.0
#3  <signal handler called>
#4  0x080e0047 in nautilus_clipboard_monitor_emit_changed ()
#5  0x080e055d in nautilus_clipboard_monitor_emit_changed ()
#6  0x080e2050 in nautilus_directory_async_state_changed ()
#7  0x080e3d27 in nautilus_directory_async_state_changed ()
#8  0x04bfc5e1 in g_source_is_destroyed () from /lib/libglib-2.0.so.0
#9  0x04bfe342 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#10 0x04c0131f in g_main_context_check () from /lib/libglib-2.0.so.0
#11 0x04c016c9 in g_main_loop_run () from /lib/libglib-2.0.so.0
#12 0x05172be4 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#13 0x0807a390 in POA_Nautilus_MetafileMonitor__init ()
#14 0x0049cf2c in __libc_start_main () from /lib/libc.so.6
#15 0x08064bd1 in g_cclosure_marshal_VOID__ENUM ()

Thread 1 (Thread -1208161536 (LWP 9105)):
#0  0x00a0e402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00601cbb in __waitpid_nocancel () from /lib/libpthread.so.0
No symbol table info available.
#2  0x04dbccf6 in gnome_gtk_module_info_get () from /usr/lib/libgnomeui-2.so.0
No symbol table info available.
#3  <signal handler called>
No symbol table info available.
#4  0x080e0047 in nautilus_clipboard_monitor_emit_changed ()
No symbol table info available.
#5  0x080e055d in nautilus_clipboard_monitor_emit_changed ()
No symbol table info available.
#6  0x080e2050 in nautilus_directory_async_state_changed ()
No symbol table info available.
#7  0x080e3d27 in nautilus_directory_async_state_changed ()
No symbol table info available.
#8  0x04bfc5e1 in g_source_is_destroyed () from /lib/libglib-2.0.so.0
No symbol table info available.
#9  0x04bfe342 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
No symbol table info available.
#10 0x04c0131f in g_main_context_check () from /lib/libglib-2.0.so.0
No symbol table info available.
#11 0x04c016c9 in g_main_loop_run () from /lib/libglib-2.0.so.0
No symbol table info available.
#12 0x05172be4 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#13 0x0807a390 in POA_Nautilus_MetafileMonitor__init ()
No symbol table info available.
#14 0x0049cf2c in __libc_start_main () from /lib/libc.so.6
No symbol table info available.
#15 0x08064bd1 in g_cclosure_marshal_VOID__ENUM ()
No symbol table info available.
#0  0x00a0e402 in __kernel_vsyscall ()
Comment 1 Matthias Clasen 2006-11-16 18:18:24 EST
Can't reproduce that here. I always get a "bluetooth://" is not a valid location
error message.
Comment 2 Alexander Larsson 2006-11-17 03:52:09 EST
Please reproduce with nautilus-debuginfo, glib2-debuginfo and gtk2-debuginfo
installed. That way we'll get a better backtrace.

Also, you could try the latest nautilus update (2.16.2-5.fc6), it has some
crasher  fixes.
Comment 3 Alexey Titov 2006-11-17 12:45:14 EST
I have no such packages in repository... But after update of nautilus to
2.16.2-5.fc6 everything became all right.

Note You need to log in before you can comment on or make changes to this bug.