Bug 215993 - "NFS version 3 is not supported" error since nfs-utils-1.0.10-1.fc6
Summary: "NFS version 3 is not supported" error since nfs-utils-1.0.10-1.fc6
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
(Show other bugs)
Version: 6
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Steve Dickson
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-16 18:40 UTC by Fabrice Bellet
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: nfs-utils-1.0.10-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-16 21:39:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Fabrice Bellet 2006-11-16 18:40:03 UTC
Hi,

there is a regression since nfs-utils-1.0.10-1.fc6, in the way NFS v3 is
handled, depending on wether -tnfs is passed on cmd line or not :

[root@lxorgfr bellet]# rpm -Uhv /tmp/nfs-utils-1.0.10-1.fc6.i386.rpm
Preparing...                ########################################### [100%]
   1:nfs-utils              ########################################### [100%]
[root@lxorgfr bellet]# mount.nfs  helix:/home/bellet/media /tmp/1  -o vers=3
NFS version 3 is not supported.
[root@lxorgfr bellet]# mount.nfs  helix:/home/bellet/media /tmp/1  -t ntfs -o vers=3
[root@lxorgfr bellet]# umount /tmp/1
[root@lxorgfr bellet]# rpm -Uhv --oldpackage  /tmp/nfs-utils-1.0.9-8.fc6.i386.rpm 
Preparing...                ########################################### [100%]
   1:nfs-utils              ########################################### [100%]
[root@lxorgfr bellet]# mount.nfs  helix:/home/bellet/media /tmp/1   -o vers=3

This error is generated, before any network activity occurs between the client
and the nfs server. If needed, I can provide a strace log.

Comment 1 Steve Dickson 2006-11-16 21:39:20 UTC
Fixed in nfs-utils-1.0.10-3.fc6


Note You need to log in before you can comment on or make changes to this bug.