Bug 216044 - 500 error on Active Users page when you have more than 1000 users.
500 error on Active Users page when you have more than 1000 users.
Status: CLOSED DUPLICATE of bug 645385
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
rhn500
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike McCune
Brandon Perkins
:
Depends On:
Blocks: 145467
  Show dependency treegraph
 
Reported: 2006-11-16 17:18 EST by Ken Ganong
Modified: 2010-11-19 15:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-19 15:12:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ken Ganong 2006-11-16 17:18:08 EST
Reproduce:
Create 1001 users.
Go to Users tab.

The reason this is happening has 2 parts:
1. The data for the new list tag on that page is elaborated all at once.
2. The way we elaborate data is by putting it all into a single query with a
list of ids.....   oracle doesn't allow that list to exceed 1000 items ( The IN
limit).

We can't just cause the list to page correctly, becuase the list has sortable
columns. Those need to access every member of the list at once.
Comment 1 Red Hat Bugzilla 2007-04-11 21:45:47 EDT
User bnackash@redhat.com's account has been closed
Comment 2 Grant Gainey 2010-11-19 15:12:28 EST
Work was done as part of 645385

*** This bug has been marked as a duplicate of bug 645385 ***

Note You need to log in before you can comment on or make changes to this bug.