Bug 21608 - ftp server out of wack
ftp server out of wack
Status: CLOSED CURRENTRELEASE
Product: Red Hat Web Site
Classification: Red Hat
Component: Download (Show other bugs)
current
i386 Linux
high Severity high
: ---
: ---
Assigned To: Tom Lancaster
Paul Lindner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-01 20:14 EST by chrismcc
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-04 12:03:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description chrismcc 2000-12-01 20:14:00 EST
Log of session:


[chrismcc@wednesday chrismcc]$ host ftp.redhat.com
ftp.redhat.com. has address 216.148.218.192
ftp.redhat.com. has address 63.240.14.64
[chrismcc@wednesday chrismcc]$ ncftp 63.240.14.64   
NcFTP 3.0.1 (March 27, 2000) by Mike Gleason (ncftp@ncftp.com).
Connecting to
63.240.14.64...                                                   FTP
server ready.
Logging
in...                                                                  
Please read the file README
  it was last modified on Tue Jan 25 08:51:37 2000 - 311 days ago
Please read the file README.roughcuts
  it was last modified on Fri Jan 21 17:32:20 2000 - 315 days ago
Guest login ok, access restrictions apply.
Logged in to
63.240.14.64.                                                      ncftp /
> cd /pub/rawhide/powertools/SRPMS
Could not chdir to /pub/rawhide/powertools/SRPMS: server said:
/pub/rawhide/powertools/SRPMS: No such file or directory.
ncftp / > ls
aic/               large-fd/          README.roughcuts   up2date/
contrib/           rawhide/           redhat/
du-s.txt           README             sound/
ncftp / > pwd
ftp://63.240.14.64


this ftp server is missing /pub
the other ftp server seems fine

added as "high" because this probably breaks stuff like up2date
Comment 1 Panic 2000-12-04 11:27:55 EST
It doesn't seem to missing /pub, it seems to be using /pub as the root entry
directory for users. If you back up one directory, you can see /pub. For
example, the link at:

http://www.redhat.com/swr/noarch/redhat-logos-1.1.2-3.noarch_dl.html

points to:

ftp://ftp.redhat.com/pub/redhat/redhat-7.0/i386/RedHat/RPMS/redhat-logos-1.1.2-3.noarch.rpm

which is broken both because of the /pub thing (I think) and because the URL is
just plain wrong -- it should be:

ftp://ftp.redhat.com/pub/redhat/redhat-7.0/i386/en/RedHat/RPMS/redhat.logos-1.1.2-3.noarch.rpm

Comment 2 chrismcc 2000-12-04 12:03:38 EST
they are also not in sync with each other


-rw-rw-r--   6 506      235        132070   Nov 10 12:00  
openldap-devel-1.2.9-6.i386.rpm
-rw-rw-r--   6 300      235        438272   Nov 12 16:07  
bind-devel-8.2.2_P7-0.6.2.i386.rpm
-rw-rw-r--   6 300      235        740240   Nov 12 16:07  
bind-utils-8.2.2_P7-0.6.2.i386.rpm
-rw-rw-r--   6 300      235       1748788   Nov 12 16:08  
bind-8.2.2_P7-0.6.2.i386.rpm
-rw-rw-r--   6 300      235       3218948   Nov 17 14:45  
netscape-navigator-4.76-0.6.2.i386.rpm
-rw-rw-r--   6 300      235       8526690   Nov 17 14:50  
netscape-common-4.76-0.6.2.i386.rpm
-rw-rw-r--   6 300      235       6051318   Nov 17 14:51  
netscape-communicator-4.76-0.6.2.i386.rpm
-rw-rw-r--   2 300      235        117650   Nov 20 10:19  
joe-2.8-42.62.i386.rpm
-rw-rw-r--   2 300      235       1528036   Nov 22 15:02  
ghostscript-5.50-8_6.x.i386.rpm
-rw-rw-r--   2 300      235        326155   Nov 22 18:47  
modutils-2.3.21-0.6.2.i386.rpm
-rw-rw-r--   2 300      235        769408   Nov 23 11:24  
ncurses-5.0-12.i386.rpm
-rw-rw-r--   2 300      235        602321   Nov 23 11:24  
ncurses-devel-5.0-12.i386.rpm
-rw-rw-r--   2 300      235        228170   Nov 27 14:05  
bash-1.14.7-23.6x.i386.rpm
ftp://63.240.14.64/up2date/rhl-6.2/i386/RedHat/RPMS/





-rw-rw-r--   4 300      235         17116   Jul 28 23:59  
gpm-devel-1.19.3-0.6.x.i386.rpm
-r--r--r--   2 root     root        24376   Jul 31 23:59   du-s.txt
-rw-rw-r--   1 300      235        564480   Aug  7 23:59  
umb-scheme-3.2-12.i386.rpm
-rw-rw-r--   1 300      235         46701   Aug  8 23:59  
mailx-8.1.1-16.i386.rpm
-rw-rw-r--   1 300      235         38606   Aug  9 23:59  
popt-1.5-9.6x.i386.rpm
-rw-rw-r--   1 300      235       1236810   Aug  9 23:59  
rpm-3.0.5-9.6x.i386.rpm
-rw-rw-r--   1 300      235         46368   Aug  9 23:59  
rpm-build-3.0.5-9.6x.i386.rpm
-rw-rw-r--   1 300      235        246948   Aug  9 23:59  
rpm-devel-3.0.5-9.6x.i386.rpm
-rw-rw-r--   1 300      235         24204   Aug  9 23:59  
rpm-python-3.0.5-9.6x.i386.rpm
-rw-rw-r--   3 300      235       8396022   Aug 18 23:59  
netscape-common-4.75-0.6.2.i386.rpm
-rw-rw-r--   3 300      235       6049019   Aug 18 23:59  
netscape-communicator-4.75-0.6.2.i386.rpm
-rw-rw-r--   3 300      235       3215141   Aug 18 23:59  
netscape-navigator-4.75-0.6.2.i386.rpm
-rw-r--r--   6 505      235       5042092   Aug 18 23:59  
perl-5.00503-12.i386.rpm
ftp://216.148.218.192/up2date/rhl-6.2/i386/RedHat/RPMS/
ncftp ...l-6.2/i386/RedHat/RPMS > 


Comment 3 Tom Lancaster 2001-04-24 18:16:14 EDT
The ftp server is no longer laid out this way.
The new layout would be /pub/redhat/linux/6.2/en/os/i386/RedHat/RPMS/...

The link currently displayed in the /swr/ section of the site is correct.

Note You need to log in before you can comment on or make changes to this bug.