Bug 21610 - Undefined references!
Summary: Undefined references!
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-02 03:49 UTC by Sammy
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-04 00:48:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sammy 2000-12-02 03:49:44 UTC
I have XFree86-4.0.1-1.3 from rawhide and glibc-2.2 as well as
everything else from rawhide installed and working (except kernel
2.2.16-22).

I am trying to compile the pcmcia package that comes with the
kernel source. Everything works ok except at the linking step
I get:

kgcc  cardinfo.o -o cardinfo -L/usr/X11R6/lib -L/usr/X11/lib -lforms -lX11
-lXpm -lm
/usr/X11R6/lib/libX11.so: undefined reference to `getpwuid_r@GLIBC_2.1.2'
/usr/X11R6/lib/libX11.so: undefined reference to `shmctl@GLIBC_2.2'
/usr/X11R6/lib/libX11.so: undefined reference to
`getpwnam_r@GLIBC_2.1.2'                 

Please advise....thanks

Comment 1 Mike A. Harris 2000-12-03 11:00:38 UTC
Do you have all XFree devel packages installed?  Looks like you might be
missing the matching header files for X.


Comment 2 Bill Nottingham 2000-12-04 00:48:04 UTC
Also, do you have glibc-devel installed?

Comment 3 Mike A. Harris 2001-02-19 13:41:41 UTC
Upgrade to the latest glibc packages, as well as the latest XFree86
packages.


Note You need to log in before you can comment on or make changes to this bug.