Bug 216156 - copying big files to USB stick in Nautilus there is no progress bar for the copy
copying big files to USB stick in Nautilus there is no progress bar for the copy
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
6
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-17 10:30 EST by Ricardo Nuno
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-20 10:33:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ricardo Nuno 2006-11-17 10:30:52 EST
Description of problem:

When copying a big file to a USB stick in Nautilus there is no progress bar for
the copy
so you never know if the file is already copy or not.

Has there is no progress bar on the copy you can remove the USB stick and you didnt
get the file that you wanted because the copy was not finished.

Version-Release number of selected component (if applicable): nautilius 2.16.2


How reproducible:

Insert the USB sitck then copy a big file like 50mb to the stick.


This is my first bug report so let me know if i have to provide any other info.

regards,
Ricardo
Comment 1 Alexander Larsson 2006-11-20 10:33:37 EST
This is tricky, if you copy a large enough file you will get a progress bar
dialog. However, if the file is small it will just fit in the buffer cache in
the kernel, and the copy will finish "immediately". The data is written out on
unmount and/or after a while. 

This is the same if you copy a file with cp.

There has recently been some work to make the UI so that when you unmount you
can tell when the unmount operation finished, and its safe to remove the stick.

Note You need to log in before you can comment on or make changes to this bug.