Bug 216168 - ACL on NFS failed intermittetly
ACL on NFS failed intermittetly
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.4
All Linux
low Severity medium
: ---
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-17 11:31 EST by Shing-Shong Shei
Modified: 2009-12-17 10:22 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-17 10:22:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The strace outupt when it failed. (5.54 KB, application/octet-stream)
2006-11-17 11:31 EST, Shing-Shong Shei
no flags Details
strace output when it works (5.61 KB, application/octet-stream)
2006-11-17 11:32 EST, Shing-Shong Shei
no flags Details

  None (edit)
Description Shing-Shong Shei 2006-11-17 11:31:42 EST
Description of problem: ACL works intermittently via NFS


Version-Release number of selected component (if applicable):


How reproducible: Not sure -- don't know how it failed and how it started
working again.  Two scripts enclosed.


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

We have a RHEL 4.4 NFS file server and when users try to use ACL on the
client machines, sometimes it works but sometimes it failed.  We don't
have a way to reproduce it reliably yet.  Luckily we caught two instances
using strace that shows a successful one and a failed one.
Comment 1 Shing-Shong Shei 2006-11-17 11:31:42 EST
Created attachment 141492 [details]
The strace outupt when it failed.
Comment 2 Shing-Shong Shei 2006-11-17 11:32:35 EST
Created attachment 141493 [details]
strace output when it works
Comment 3 Shing-Shong Shei 2006-12-02 11:11:17 EST
Anybody home?  Has this case been taken?
Thanks.  --Bruce
Comment 4 Kamil Dudka 2009-12-17 10:01:18 EST
In both cases strace output is exactly the same until the first getxattr syscall, which returns ENODATA. This means it can't be a bug of getfacl. It might be caused by NFS or more likely the remote server.

Any chance the remote file could be alternated between the tests?
Comment 5 Shing-Shong Shei 2009-12-17 10:11:16 EST
> Any chance the remote file could be alternated between the tests?

Wow three years later, finally somebody starts to look into this issue.  Frankly speaking, it's been so long that I cannot even recall the details.  But if you want an answer, I'd say that the remote file has not been changed for sure as during the test, no reason for me to change it, especially when I tried to make a case.  Anyway, we have since moved to RHEL 5 and have not seen this error.  So we can close this case now.  Thanks for looking into it.  Have a Happy Holidays.
Comment 6 Kamil Dudka 2009-12-17 10:22:40 EST
Sorry for the delay. Don't blame me as I got the ACL package three hours ago :-) Thanks for the additional info. I am closing the bug as NEXTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.