Bug 21619 - apropos breaks when /usr/man/whatis contains non-ASCII chars
apropos breaks when /usr/man/whatis contains non-ASCII chars
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: man (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Aaron Brown
:
: 24121 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-02 13:08 EST by Ed Avis
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-16 12:35:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed Avis 2000-12-02 13:08:54 EST
Some packages' man pages (not from Red Hat) contain funny characters in the
summary line.  This seems to happen especially with mathematics libraries
which have funny characters for mathematical symbols.  This breaks apropos,
because it uses grep and grep doesn't print matching lines from a 'binary
file'.

Thus you get:

% apropos sgml
Binary file /usr/man/whatis matches

These packages are behaving badly by putting weird characters into their
man pages, but apropos should be able to cope.

The fix is to pass the -a or --text flag to grep.  This can be done by
changing a couple of lines in /usr/bin/apropos:

aproposgrepopt1='ia'
aproposgrepopt2=''
whatisgrepopt1='iwa'
whatisgrepopt2='^'

The same change needs to be made to /usr/bin/whatis - in fact they are the
same file apart from one tiny change.  I think the intention is that one be
a symlink to the other and then the program looks at $0 when run - I'm not
sure why you've chosen not to do it like this.
Comment 1 Need Real Name 2001-01-16 12:35:14 EST
Look at bugzilla 24121 - I have fixed this in the srpm...
Comment 2 Bernhard Rosenkraenzer 2001-04-25 04:59:35 EDT
Fixed in 1.5i-1
Comment 3 Bernhard Rosenkraenzer 2001-04-25 05:07:21 EDT
*** Bug 24121 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.