Bug 216206 - up2date fails for openssh-server 17.1 with %pre failure
up2date fails for openssh-server 17.1 with %pre failure
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: openssh (Show other bugs)
4.4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-17 14:49 EST by Subhendu Ghosh
Modified: 2016-10-04 00:28 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-21 13:24:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Subhendu Ghosh 2006-11-17 14:49:17 EST
Description of problem:
openssh-server-3.9p1-8.RHEL4.17.1.i386 fails to install 

Version-Release number of selected component (if applicable):
-3.9p1-8.RHEL4.17.1.i386

How reproducible:
Always

Steps to Reproduce:
1. up2date --nox openssh-server
or 
1.  rpm -Uvh openssh-server-3.9p1-8.RHEL4.17.1.i386.rpm

 
Actual results:

Preparing...                ########################################### [100%]
error: %pre(openssh-server-3.9p1-8.RHEL4.17.1.i386) scriptlet failed, exit
status 255
error:   install: %pre scriptlet failed (2), skipping
openssh-server-3.9p1-8.RHEL4.17.1

Expected results:

successful installation
Additional info:
SELinux permissive
Comment 1 Tomas Mraz 2006-11-20 14:03:56 EST
I'm unable to reproduce this problem here. Have you tried repeatedly downgrading
(--oldpackage) and upgrading to openssh-server-3.9p1-8.RHEL4.17.1 and
openssh-server-3.9p1-8.RHEL4.17?
Comment 2 Subhendu Ghosh 2006-11-21 09:55:21 EST
downgrade fails as well:

rpm --oldpackage -Uvh openssh-server-3.9p1-8.RHEL4.15.i386.rpm
openssh-3.9p1-8.RHEL4.15.i386.rpm openssh-clients-3.9p1-8.RHEL4.15.i386.rpm
openssh-askpass-3.9p1-8.RHEL4.15.i386.rpm
openssh-askpass-gnome-3.9p1-8.RHEL4.15.i386.rpm
Preparing...                ########################################### [100%]
   1:openssh                ########################################### [ 20%]
error: %pre(openssh-server-3.9p1-8.RHEL4.15.i386) scriptlet failed, exit status 255
error:   install: %pre scriptlet failed (2), skipping
openssh-server-3.9p1-8.RHEL4.15
   2:openssh-clients        ########################################### [ 40%]
   3:openssh-askpass        ########################################### [ 60%]
   4:openssh-askpass-gnome  ########################################### [ 80%]
# rpm -qa | grep openssh
openssh-server-3.9p1-8.RHEL4.17
openssh-3.9p1-8.RHEL4.15
openssh-clients-3.9p1-8.RHEL4.15
openssh-askpass-3.9p1-8.RHEL4.15
openssh-askpass-gnome-3.9p1-8.RHEL4.15

Trying to uninstall openssh-server and netdump-server also fails:
# rpm -e openssh-server netdump-server
error: %preun(netdump-server-0.7.16-2.i386) scriptlet failed, exit status 255
error: %preun(openssh-server-3.9p1-8.RHEL4.17.i386) scriptlet failed, exit
status 255

Looks like I may have a borked scriplet execution environment.
Comment 3 Tomas Mraz 2006-11-21 13:24:06 EST
It seems so there is something seriously broken on your machine. Various
scriptlets are crashing.

Closing as NOTABUG as this is definitely not a bug in openssh.

Note You need to log in before you can comment on or make changes to this bug.