Bug 216250 - yumdownloader seems to do everything twice
Summary: yumdownloader seems to do everything twice
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
(Show other bugs)
Version: 6
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-17 23:42 UTC by Ian Collier
Modified: 2007-11-30 22:11 UTC (History)
5 users (show)

Fixed In Version: 1.0.2-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-14 09:18:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix yumdownloader to only call my.doConfigSetup once (788 bytes, patch)
2006-12-18 22:05 UTC, Matt McCutchen
no flags Details | Diff

Description Ian Collier 2006-11-17 23:42:18 UTC
Description of problem:
"yum" seems happy with my configuration, but "yumdownloader" claims everything
is "listed more than once in the configuration".

Version-Release number of selected component (if applicable):
yum-utils-1.0.1-1.fc6

How reproducible:
always

Steps to Reproduce:
1. yumdownloader --url yum-utils
  
Actual results:
Loading "installonlyn" plugin
Loading "installonlyn" plugin
Repository development is listed more than once in the configuration
Repository development is listed more than once in the configuration
Repository legacy-updates is listed more than once in the configuration
Repository legacy-updates is listed more than once in the configuration
Repository core is listed more than once in the configuration
Repository core is listed more than once in the configuration
[lots more messages]
Repository livna-testing-source is listed more than once in the configuration
Repository livna-testing-source is listed more than once in the configuration
Repository core-debuginfo is listed more than once in the configuration
Repository core-debuginfo is listed more than once in the configuration
http://mirrorservice.org/sites/download.fedora.redhat.com/pub/fedora/linux/extras/6/i386/yum-utils-1.0.1-1.fc6.noarch.rpm
http://mirrorservice.org/sites/download.fedora.redhat.com/pub/fedora/linux/extras/6/i386/yum-utils-1.0.1-1.fc6.noarch.rpm

Expected results:
only the first and last lines of the above

Additional info:
I haven't changed much in the configuration since installation:

$ rpm -V yum yum-utils fedora-release-6-4 livna-release-6-1
..5....T c /etc/yum/pluginconf.d/installonlyn.conf
S.5....T c /etc/yum.repos.d/fedora-core.repo
S.5....T c /etc/yum.repos.d/fedora-extras.repo
S.5....T c /etc/yum.repos.d/fedora-updates.repo

Behaviour was the same before I edited installonlyn.conf to change 2 to 3.
The three repo files were edited to change the baseurls and add
failovermethod=priority.  All other repo files are unchanged.

$ ls /etc/yum.repos.d/
fedora-core.repo                fedora-legacy.repo           livna-testing.repo
fedora-development.repo         fedora-updates-testing.repo  livna.repo
fedora-extras-development.repo  fedora-updates.repo
fedora-extras.repo              livna-devel.repo

Comment 1 Luke Macken 2006-12-02 21:01:42 UTC
I am able to reproduce this on two FC6 machines.

Comment 2 Matt McCutchen 2006-12-18 22:05:31 UTC
Created attachment 143950 [details]
Fix yumdownloader to only call my.doConfigSetup once

Aha: yumdownloader was calling my.doConfigSetup twice.	I merged the two calls
into one, and that seemed to both unduplicate the lines of output and get rid
of the "repository is listed more than once" errors.

Comment 3 Tim Lauridsen 2007-02-14 09:18:07 UTC
This bug is fixed in current yum-utils-1.0.2



Comment 4 Matt McCutchen 2007-02-14 13:54:41 UTC
I verified that yumdownloader no longer does everything twice.  Thanks!


Note You need to log in before you can comment on or make changes to this bug.