This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 216261 - Impossible to create a submenu which absorbs entries from another menu + fix
Impossible to create a submenu which absorbs entries from another menu + fix
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: redhat-menus (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-18 03:14 EST by Hans de Goede
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 6.7.8-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-22 17:06:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2006-11-18 03:14:47 EST
I'm a Fedora Extras packager mainly active in packaging / maintaining games as
such I've got a very large list of games under my games menu. 

I've been trying to create a .menu file to drop in
/etc/xdg/menus/applications.menu which adds submenus to the game menu based on
the XxxxGame catagories listed under "Additional Category" here:
http://standards.freedesktop.org/menu-spec/latest/apa.html

This works, but I also want them to no longer show up in the "main" games menu,
iow I only want .desktop entries which are not already under one of my submenu's
to show up under the Games menu, this unfortunately currently seems not possible.

I've tried 3 approaches.
1) Try to override the whole Games menu <Include> and extend it with a 
   <And><Not> for each "Additional Category" which I've put in its own submenu
   doesn't work.
2) Try to <Exclude> the "Additional Category" 's, doesn't work
3) Add a <OnlyUnallocated/> tag, this works, but now all the games which are
   not in one of the submenu's also show up in the Other menu :(

Although the behavour under 3 is strange, from some pov it may be desirable but
the behaviour under 1 and 2 is not desirable IMHO. I've done some googling and
it turns out that this is a parsing order problem. For 1) and/or 2) to work
applications-merged must be parsed at the end of applications.menu, I've checked
the other uses of applications-merged currently installed on my fairly complete
install and they are parsing order independend, iow they shouldn't suffer any
bad effects from moving the parsing of applications-merged to the end of
applications.menu

The original post I found on google on the parsing order issue is here:
http://ubuntuforums.org/showthread.php?t=139901

Surprisingly this guy has also tried the same 3 methods. Also there are other
fedora users who've tried this and failed too:
http://www.redhat.com/archives/fedora-devel-list/2006-March/msg01678.html

Last I'm not alone in wanting these submenus, we have had discussions about this
on the fedora-games-list, which mostly gets used by the Fedora Extras Games SIG
in the past. IOW please fix this :)
Comment 1 Rickey Moore 2006-11-18 19:43:14 EST
Please see if this can be resolved as I wish to use this game for a project that
I am working on. Brotherly Love and World Peace could be a result! Ha! For real!
If I can shoe-horn glest into one of his $100 laptops, I've got 2.7 million
clients to put it in front of, just for starts, across the country and later the
world. No fooling! <grins hugely> 

Please try to put this one up in the que for wayward4now and his OAR project, as
a personal request from a former RedHatter. I worked at the RTP location in
1999-2000. Hopefully, Nicholas Negroponte will thank you one day as well, if I
can get a proof-of-concept running to show him. If you are in the RTP location
as well, I already have approvals from the NCDOC, and this could be an entry
point into the State IT structure as well as I am going to insist that as an
Open Source Project that it use a North Carolina Product as well. Governor Mike
will agree if it works. So, please do what you can to expedite this for the
Gentleman who is doing a good thing here. Thank you for any considerations, Ric
Comment 2 Hans de Goede 2006-11-19 02:02:14 EST
Are you sure you wanted to post that as a comment to this bug???
Comment 3 Ray Strode [halfline] 2006-11-20 11:09:39 EST
So just to be sure, you've tried moving <DefaultMergeDirs/> to after the Other
menu bits and it

1) fixes your problem 
and
2) doesn't obviously break anything else?

Comment 4 Hans de Goede 2006-11-20 13:49:04 EST
(In reply to comment #3)
> So just to be sure, you've tried moving <DefaultMergeDirs/> to after the Other
> menu bits and it
> 
> 1) fixes your problem 
> and
> 2) doesn't obviously break anything else?
> 
> 

Correct.

Comment 5 Ray Strode [halfline] 2006-11-20 14:42:32 EST
okay i've pushed an update to rawhide and FC-6 updates-testing that should be
showing up shortly.

can you verify that the fix i pushed works?
Comment 6 Hans de Goede 2006-11-22 17:06:49 EST
I can confirm that the update in rawhide fixes this for me, thanks! Closing.

Note You need to log in before you can comment on or make changes to this bug.