Bug 216270 - Automount causes /proc filesystem problems
Automount causes /proc filesystem problems
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks: 208757
  Show dependency treegraph
 
Reported: 2006-11-18 08:07 EST by W. Michael Petullo
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-19 14:25:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description W. Michael Petullo 2006-11-18 08:07:43 EST
Description of problem:
Starting automount with /etc/init.d/autofs causes /proc to unmount.  Once /proc
is unmounted, I am unable to remount it.  "mount -t proc none /proc" says "wrong
fs type..."

Version-Release number of selected component (if applicable):
kernel-2.6.18-1.2849.fc6
autofs-5.0.1-0.rc2.22

How reproducible:
Every time

Steps to Reproduce:
1. ls /proc
2. /etc/init.d/autofs start
3. ls /proc
4. mount -t proc none /proc
  
Actual results:
Step on displays the contents of the proc filesystem.  In step 2, autofs fails
to start.  In step 3, the proc filesystem is not listed.  Mounting the proc
filesystem is step 4 fails with "wrong fs type..."

Expected results:
Automount should start.  It certainly shouldn't make the kernel unable to mount
the proc filesystem.

Additional info:
My system is a PowerPC iBook.  SELinux is enforcing its targeted policy.
Comment 1 Ian Kent 2006-11-18 11:17:12 EST
(In reply to comment #0)
> Description of problem:
> Starting automount with /etc/init.d/autofs causes /proc to unmount.  Once /proc
> is unmounted, I am unable to remount it.  "mount -t proc none /proc" says "wrong
> fs type..."

I can confirm that autofs doesn't attempt to mount /proc.
However it is not specifically checked for in maps.

That can change if there is any doubt.

Ian
Comment 2 W. Michael Petullo 2006-11-18 18:17:36 EST
Ian, it seems that automount is doing something that exposes a bug in the
kernel.  I wonder if this is a PowerPC-specific issue?  I know that
/etc/init.d/autofs does not mount or unmount /proc explicitly.  This is why I
suspect something is causing the kernel to malfunction.  I further believe this
because once /proc is unmounted, I am unable to remount it by hand.  This makes
me think something went wrong in the kernel.
Comment 3 Ian Kent 2006-11-19 08:57:22 EST
(In reply to comment #2)
> Ian, it seems that automount is doing something that exposes a bug in the
> kernel.  I wonder if this is a PowerPC-specific issue?  I know that
> /etc/init.d/autofs does not mount or unmount /proc explicitly.  This is why I
> suspect something is causing the kernel to malfunction.  I further believe this
> because once /proc is unmounted, I am unable to remount it by hand.  This makes
> me think something went wrong in the kernel.

Before we go down this path is there anything in your
maps that even has a substring anything like proc?

Ian
Comment 4 W. Michael Petullo 2006-11-19 14:25:59 EST
NOTABUG: A typo in one of my maps was causing autofs to manage /.

Note You need to log in before you can comment on or make changes to this bug.