Bug 216287 - KDE system on fc6 (and fc5 for one machine) keeps "self-altering" incorrectly.
KDE system on fc6 (and fc5 for one machine) keeps "self-altering" incorrectly.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-18 14:39 EST by William W. Austin
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: FC6-update
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-20 05:10:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
detailed description of the menu system problem. (4.64 KB, text/plain)
2006-11-18 14:39 EST, William W. Austin
no flags Details

  None (edit)
Description William W. Austin 2006-11-18 14:39:48 EST
Description of problem:
The default init level for this system is 3.  Whenever I startx, the KDE menu
system is different from the previous session.  Menu entries changed or removed
altogether, new empty menus created (ex. old was Favorites with 23 entires, new
might be Favorites-2 with 3 entries).  LONG description attached below


Version-Release number of selected component (if applicable):
kdebase-3.5.5-0.4.fc6, kernel-2.6.18-1.2849.fc6, glibc-2.5-3.  (In case it
helps, this is a dual-core athlon-64)


How reproducible:
every time


Steps to Reproduce:
1.startx
2.try to use kde "all applications" menu (bottom left of panel)
3.
  
Actual results:
Menu structure will be slightly different from that in previous session even
though nothing has been updated on system (no rpms added or deleted, and no
changes to menu by user).  (see attachment at end)


Expected results:
Menu should not have deletions or addition of empty menu dir's


Additional info:
This started fairly recently - I went from fc4 to fc5 and then 3 weeks later
installed fc6 on this machine.  One other non-privileged user has the same
results on this machine, but this also occurs for root. (it might for the other
n-p users, but I haven't tested long enough to find out).  BUT on another fc5
machine with home dir's built from those on THIS macine, the results are the
same - root and my logins show this problem, the others don't.
Comment 1 William W. Austin 2006-11-18 14:39:48 EST
Created attachment 141567 [details]
detailed description of the menu system problem.
Comment 2 Ngo Than 2006-11-20 05:10:11 EST
you should please try following steps:

- login into KDE with your login name
- mv $HOME/.config HOME/.config.orig
- kbuildsycoca --noincremental

the menus should be ok after this action.

it's a bug in the old kde version which causes this issue. The bug is now 
resolved in new kde version, but the side affect is that the user has to do 
the obove steps once to get the menu back in some cases.

Thanks for your report
Comment 3 William W. Austin 2006-11-21 10:10:14 EST
This worked on the fc6 machine, but it did *not* work on the fc5 box - no idea why. 

On the fc5 box the following did NOT work:
    exit x windows
    mkdir ~/OTHER
    mv .kde .kderc ~/OTHER
    in /tmp and /var/tmp remove .ICE-unix .X* .esd .sockets and *-<my user name>
    finally reboot box
    start up xwindows again.

What I finally did which worked was to do all of the above plus move all of the
  .gconf* and .gnome* to ~/OTHER as well.  Ater the reboot I logged in, set my
desktop and recofigured for an hour.  (on fc5 - your instructions worked fine on
fc6).  I am still getting the extra/renamed directories under .kde/share/applnk,
but the menus continue to display correctly.

Thanks for the help.


Note You need to log in before you can comment on or make changes to this bug.