Bug 216297 - Compiz on AIGLX causes blue screen
Compiz on AIGLX causes blue screen
Status: CLOSED DUPLICATE of bug 210760
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
6
powerpc Linux
medium Severity high
: ---
: ---
Assigned To: Adam Jackson
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-18 18:45 EST by Troels Just
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-27 11:23:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch that should fix this problem, which I ran into while researching this problem on different distros' bug-trackers. (406 bytes, patch)
2006-11-18 18:45 EST, Troels Just
no flags Details | Diff
My X.Org configuration file (963 bytes, application/octet-stream)
2006-11-21 08:24 EST, Troels Just
no flags Details
My X.Org log file (52.21 KB, text/plain)
2006-11-21 08:25 EST, Troels Just
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 8095 None None None Never

  None (edit)
Description Troels Just 2006-11-18 18:45:59 EST
Description of problem:
Because of an endianness bug in the AIGLX GLX_EXT_texture_from_pixmap
implementation, when running Compiz or Beryl the screen gets all blue.
This bug is fixed upstream.

Version-Release number of selected component (if applicable):
1.1.1-47

How reproducible:
very easy to reproduce.

Steps to Reproduce:
1. Install the final version of Fedora Core 6 on a PowerPC machine.
2. Use the simple Desktop Effects tool to enable Compiz.
  
Actual results:
The screen gets a layer of blue added to it, which causes parts it to also get
pink and purple.

Expected results:
Compiz to just function normally, as it does on x86 and AMD64.

Additional info:
I ran into this problem on my PowerPC G4-based Mac mini, which uses a Radeon
9200 graphics chip. I know people with iBooks, also using the 9200 chip, have
also run into this problem.
Comment 1 Troels Just 2006-11-18 18:45:59 EST
Created attachment 141572 [details]
Patch that should fix this problem, which I ran into while researching this problem on different distros' bug-trackers.
Comment 2 Matěj Cepl 2006-11-21 07:57:27 EST
Thanks for the bug report.  We have reviewed the information you
have provided above, and there is some additional information we
require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X
server log file (/var/log/Xorg.*.log) to the bug report as individual
uncompressed file attachments using the bugzilla file attachment link
below.

We will review this issue again once you've had a chance to attach
this information.

Thanks in advance.
Comment 3 Troels Just 2006-11-21 08:24:42 EST
Created attachment 141761 [details]
My X.Org configuration file
Comment 4 Troels Just 2006-11-21 08:25:59 EST
Created attachment 141762 [details]
My X.Org log file
Comment 5 Troels Just 2006-11-21 08:37:05 EST
(In reply to comment #2)
> Thanks for the bug report.  We have reviewed the information you
> have provided above, and there is some additional information we
> require that will be helpful in our diagnosis of this issue.
> 
> Please attach your X server config file (/etc/X11/xorg.conf) and X
> server log file (/var/log/Xorg.*.log) to the bug report as individual
> uncompressed file attachments using the bugzilla file attachment link
> below.
> 
> We will review this issue again once you've had a chance to attach
> this information.
> 
> Thanks in advance.

I have posted the files you requrested, I hope to have this fixed relatively
soon, because what's a presentation using a projector worth without a properly
working Compiz? :P
Comment 6 Francesco Ugolini 2006-12-04 16:18:55 EST
I've the same problem with both iBook and Mac Mini with compiz and AIGLX too. I
hope that this problem can be solved (if you want i can attach myxorg confifg
and log).
Comment 7 Edward Rudd 2007-01-07 23:58:13 EST
duplicate of #210760
Comment 8 Lionel H. 2007-01-14 13:42:35 EST
I'm experiencing the same problem here on a mac mini.
I suppose that anyone running compiz on a ppc is facing this bug.
Comment 9 Adam Jackson 2007-03-27 11:23:01 EDT

*** This bug has been marked as a duplicate of 210760 ***

Note You need to log in before you can comment on or make changes to this bug.