Bug 216298 - scp tries to load old lib libcrypto.so.2
scp tries to load old lib libcrypto.so.2
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: openssh (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-18 20:29 EST by Dave Blackburn
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-20 03:27:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dave Blackburn 2006-11-18 20:29:11 EST
Description of problem:
scp: error while loading shared libraries: libcrypto.so.2: cannot open shared
object file: No such file or directory

This seems to be an old lib -- not on my FC5 system updated with yum.


Version-Release number of selected component (if applicable):
openssh-clients-4.3p2-4.10

How reproducible:
as root
scp ~/.ssh/id_rsa.pub root@$h:~/.ssh/authorized_keys2
where $h is another host on same subnet

Steps to Reproduce:
1.
2.
3.
  
Actual results:
scp: error while loading shared libraries: libcrypto.so.2: cannot open shared
object file: No such file or directory


Expected results:
scp to load the current libcrypto.so.6 or libcrypto.so.0.9.8a
or, if necessary, make libcrypto.so.2 available in repos with a dep from
openssh-clients-4.3p2-4.10 (and other if appropriate).

Additional info:
I installed openssh*-4.3p2-4.1 in place of *4.10
scp now runs OK.

My system:
Linux <host> 2.6.17-1.2187_FC5 #1 Mon Sep 11 01:17:06 EDT 2006 i686 i686 i386
GNU/Linux

/lib/libcrypto.so.6
/lib/libcrypto.so.0.9.8a
both from: openssl-0.9.8a-5.4

Related suggestion:
The normal repositories didn't have openssh*-4.3p2-4.1 
I had to find another repos by web search before I
could use yum to downgrade to openssh*-4.3p2-4.1 
Perhaps keeping older updates in the update repos would be worthwhile unless
it's more hassle than it's worth.
Comment 1 Tomas Mraz 2006-11-20 03:27:40 EST
There must be something seriously broken on your system. I have verified that
the scp in openssh-clients-4.3p2-4.10 requests libcrypto.so.6 and not
libcrypto.so.2. 

Isn't it possible that you somehow accidentaly overwritten scp with a different
binary?
libcrypto.so.2 is from openssl-0.9.6b which is not shipped in Fedora for a long
time.

Note You need to log in before you can comment on or make changes to this bug.