Bug 21631 - Screen corrupts for ATI Rage 128
Screen corrupts for ATI Rage 128
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-02 17:41 EST by Stephen Rasku
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-06 15:00:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XF86Config file. (14.04 KB, text/plain)
2000-12-05 01:36 EST, Stephen Rasku
no flags Details
Error when using discrete HorizSync and VertRefresh values (1018 bytes, text/plain)
2000-12-06 15:00 EST, Stephen Rasku
no flags Details

  None (edit)
Description Stephen Rasku 2000-12-02 17:41:07 EST
I have problems with the display writing places that it shouldn't.  Text
gets written to the left or right and sometimes the toolbar at the top gets
overwritten. It is especially noticeable when I run slrn.  I have Xpert
Rage 128 16M card and the problem goes away when I enable "no_accel" in
XF86Config.  

I am running /usr/X11R6/bin/XF86_SVGA* as my server.  I tried to run the
Mach64 server but it wouldn't start up and I tried the Mach32 server but it
hung my machine.
Comment 1 Bill Nottingham 2000-12-03 19:48:58 EST
That's the wrong server in both cases. You need to use XFree4
and the r128 driver...
Comment 2 Stephen Rasku 2000-12-05 01:34:19 EST
As far as I know, I am running XFree4.  I changed the server by changing the
link that /etc/X11/X points to.  It is currently pointing to
../../usr/X11R6/bin/XF86_SVGA.

I attempted to load the r128 driver by adding:

	Driver 	"r128"

to the "Device" section.  When I did that, I got:

	Config Error: /usr/X11R6/lib/X11/XF86Config:349
 
	    Driver      "r128"
	    ^^^^^^^
	Unknown device section keyword
 
	Fatal server error:                                                             

I will attach my entire XF86Config file below.
Comment 3 Stephen Rasku 2000-12-05 01:36:45 EST
Created attachment 6032 [details]
XF86Config file.
Comment 4 Bill Nottingham 2000-12-05 11:03:33 EST
XF86_SVGA is *not* the XFree 4 server. You need to have
/etc/X11/X pointing at /usr/X11R6/bin/XFree86. It uses
/etc/X11/XF86Config-4.
Comment 5 Stephen Rasku 2000-12-06 14:58:24 EST
OK, I managed to get migrate my XF86Config file to an XF86Config-4 file.  Is
there any documentation on this?  Also, I noticed a few things:

1. The HorizSync and and VertRefresh entries doesn't support discrete values
even though the man page, XF86Config(5x), says it does.
2. The desktop icons (e.g. Trash can) now have a black background instead of an
invisible background so you can't see the desktop background behind the icon.
Comment 6 Stephen Rasku 2000-12-06 15:00:55 EST
Created attachment 6112 [details]
Error when using discrete HorizSync and VertRefresh values
Comment 7 Stephen Rasku 2000-12-22 03:12:40 EST
Issue #1 above is resolved by using KDE 2.  Issue #2 has been filed as bug
22723.  The original problem is solved so marking this WORKSFORME.

Note You need to log in before you can comment on or make changes to this bug.