Bug 216330 - Can write to read-only logical volume
Can write to read-only logical volume
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alasdair Kergon
Corey Marthaler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-19 06:16 EST by Vlado Potisk
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version: lvm2-2.02.17-1.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-29 09:59:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vlado Potisk 2006-11-19 06:16:13 EST
Description of problem:
Write access is granted to logical volume set to read-only.

Version-Release number of selected component (if applicable):
lvm2-2.02.06-4

How reproducible:
Always

Steps to Reproduce:
(as root)
1. create a logical volume, e.g. /dev/myvg/test
2. run: lvchange -pr /dev/myvg/test
3. (optional) check with: lvdisplay /dev/myvg/test
   it displays: LV Write Access read only
4. create a filesystem: mke2fs /dev/myvg/test
  
Actual results:
It is possible to create a filesystem (and also to mount it, and store data there)

Expected results:
It should not be allowed to modify the logical volume in any way while it is
read-only.

Additional info:
Comment 1 Vlado Potisk 2006-11-19 06:40:08 EST
After reboot is the test LV read-only, but now it is not possible to make it
read-write again. It's the same problem reversed. It looks like the lvchange
command changes the permissions in the configuration, but fails to make the
changes active in the kernel.
Comment 2 Alasdair Kergon 2006-11-19 15:18:00 EST
can't reproduce with upstream code - assume this'll be fixed when I next update
the fc6 package
Comment 3 Corey Marthaler 2006-12-20 13:26:39 EST
Fix verified in lvm2-2.02.17-1. 

I couldn't mkfs or dd to the ro device.
Comment 4 Fedora Update System 2007-01-10 15:27:50 EST
lvm2-2.02.17-1.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 5 Fedora Update System 2007-01-22 12:02:40 EST
lvm2-2.02.17-1.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 6 Vlado Potisk 2007-01-27 13:52:52 EST
I have installed the latest updates including the lvm2 package mentioned above
on my system. The issue is resolved, thank you.

Note You need to log in before you can comment on or make changes to this bug.