Bug 216341 - busy loop in malloc can hang the machine
Summary: busy loop in malloc can hang the machine
Status: CLOSED WONTFIX
Alias: None
Product: Fedora Legacy
Classification: Retired
Component: glibc (Show other bugs)
(Show other bugs)
Version: rhl9
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Fedora Legacy Bugs
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-19 15:44 UTC by Julien Ducourthial
Modified: 2016-11-24 15:01 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-30 19:57:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
program to show the problem (2.15 KB, text/x-csrc)
2006-11-19 15:44 UTC, Julien Ducourthial
no flags Details
patch to correct the problem (2.29 KB, patch)
2006-11-19 15:49 UTC, Julien Ducourthial
no flags Details | Diff

Description Julien Ducourthial 2006-11-19 15:44:29 UTC
Description of problem:
when using real time thread (with SCHED_FIFO policy) and malloc, the machine can
get stuck in malloc when another thread is doing some fork.
After checking the source there is a busy loop in get_arena2 (in malloc/arena.c)
which can occurs in fork situations. 
This problem have been corrected in RHEL3.

Version-Release number of selected component (if applicable):
2.3.2-27.9.7

How reproducible:
systematic

Steps to Reproduce:
1. log in as root
2. run the attached program malloc_bug
3. 
  
Actual results:
the program aborts because it detects a hang situation

Expected results:
the program shall run flawlessly.

Additional info:

Comment 1 Julien Ducourthial 2006-11-19 15:44:29 UTC
Created attachment 141584 [details]
program to show the problem

Comment 2 Julien Ducourthial 2006-11-19 15:49:21 UTC
Created attachment 141585 [details]
patch to correct the problem

this patch is a backport of the patch that was done by U.Drepper on
glibc-2.3.2-95.31 to correct the problem on RHEL3.

Comment 3 Jesse Keating 2007-08-30 19:57:30 UTC
Fedora Legacy project has ended.  These will not be fixed by Fedora Legacy.


Note You need to log in before you can comment on or make changes to this bug.