This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 216348 - New version is incompatible with old .eclipse directory
New version is incompatible with old .eclipse directory
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ben Konrath
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-19 15:02 EST by Mary Ellen Foster
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 3.2.1-23.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-31 17:28:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Log file generated by following steps described (13.40 KB, text/plain)
2006-11-19 15:02 EST, Mary Ellen Foster
no flags Details

  None (edit)
Description Mary Ellen Foster 2006-11-19 15:02:09 EST
Description of problem:
Installing the update from updates-testing (eclipse-3.2.1-17.fc6) breaks my
Eclipse configuration, even with a basically pristine .eclipse directory. Moving
the .eclipse directory out of the way lets the new version start, so I think
it's some configuration thing that's different between the two versions.

The error says to look in a config file under
~/.eclipse/org.eclipse.platform_3.2.0/configuration. I'll attach one instance of
that file. In my attachment, I think that the first error (about the update
configurator) is not related; the relevant error message (that I saw in all such
log files) seems to be:

org.osgi.framework.BundleException: The bundle could not be resolved. Reason:
Missing Constraint: Require-Bundle: org.eclipse.core.jobs;
bundle-version="[3.2.0,4.0.0)"
[ ... backtrace ... ]

Bundle
initial@reference:file:plugins/org.eclipse.core.runtime_3.2.0.v20060603.jar/ was
not resolved.

[ ... ]



Version-Release number of selected component (if applicable):
eclipse-3.2.1-17.fc6

How reproducible:
Always

Steps to Reproduce:
1. (with old Eclipse installed) mv .eclipse .eclipse.bak
2. run eclipse (creates new .eclipse directory)
3. update to new Eclipse
4. run eclipse
  
Actual results:
Crash as described above

Expected results:
Eclipse running
Comment 1 Mary Ellen Foster 2006-11-19 15:02:09 EST
Created attachment 141593 [details]
Log file generated by following steps described
Comment 2 Andrew Overholt 2006-11-19 16:37:29 EST
It's because we moved the platform-specific stuff to /usr/lib (or
/usr/lib64).  There's no way around the .eclipse breakage.  We're going to put
some information in the update text before moving from updates-testing to updates.
Comment 3 Andrew Overholt 2006-11-28 15:14:00 EST
I was wrong.  This should be fixed by the forthcoming eclipse-3.2.1-23.fc6 test
update.  Please test it and let us know if it works for you without modifying
~/.eclipse from stock FC6.
Comment 4 Mary Ellen Foster 2006-12-01 05:15:24 EST
Just tested with the new version of Eclipse and my old ~/.eclipse directory, and
everything seems fine. "diff" indicates that it created a file called
".homedirmodified-fedora" and added a number of paths to
org.eclipse.platform_3.2.0/configuration/org.eclipse.update/platform.xml -- I
assume that's what the fix does.
Comment 5 Mary Ellen Foster 2006-12-01 05:25:28 EST
Huh. Possibly spoke too soon. I had subclipse installed from the update site in
that .eclipse directory, and when I go to the "Team / SVN" Preferences page, I
get a warning about "JavaHL interface is not available. Check your environment.".

The full warning is:
"Failed to load JavaHL Library.
These are the errors that were encountered:
no libsvnjavahl-1 in java.library.path
no svnjavahl-1 in java.library.path
no svnjavahl in java.library.path
java.library.path =
/usr/lib/jvm/java-1.5.0-sun-1.5.0.09/jre/lib/i386/client:/usr/lib/jvm/java-1.5.0-sun-1.5.0.09/jre/lib/i386:/usr/lib/jvm/java-1.5.0-sun-1.5.0.09/jre/../lib/i386:/usr/lib/firefox-2.0"

If I change the checkbox from JavaHL to JavaSVN, everything seems happy. This
could well be due to some other weirdness in that .eclipse configuration or in
my workspace (which I've been using with a different .eclipse directory), though ...
Comment 6 Andrew Overholt 2006-12-01 08:43:02 EST
(In reply to comment #5)
> Huh. Possibly spoke too soon. I had subclipse installed from the update site in
> that .eclipse directory, and when I go to the "Team / SVN" Preferences page, I
> get a warning about "JavaHL interface is not available. Check your environment.".

Yeah, that's a known subclipse issue.  I don't know the bug # off the top of my
head, but it's unrelated.  That is, unless you had that preference already
checked and it reverted?
Comment 7 Andrew Overholt 2006-12-01 08:44:18 EST
(In reply to comment #4)
> Just tested with the new version of Eclipse and my old ~/.eclipse directory, and
> everything seems fine. "diff" indicates that it created a file called
> ".homedirmodified-fedora" and added a number of paths to
> org.eclipse.platform_3.2.0/configuration/org.eclipse.update/platform.xml -- I
> assume that's what the fix does.

Yup.  Thanks for checking.
Comment 8 Mary Ellen Foster 2006-12-01 08:47:08 EST
(In reply to comment #6)
> Yeah, that's a known subclipse issue.  I don't know the bug # off the top of my
> head, but it's unrelated.  That is, unless you had that preference already
> checked and it reverted?

No, this seems to have been broken in my subclipse config for a bit now, and I
just never noticed until testing this update. Sorry for the false alarm.
Comment 9 Ben Konrath 2006-12-01 09:00:42 EST
The subclipse issue is bug #194026.
Comment 10 Ben Konrath 2007-01-31 17:28:13 EST
The original problem was fixed in 3.2.1-23.fc6. Closing bug.

Note You need to log in before you can comment on or make changes to this bug.