Bug 216419 - EL6 path in installation tree
EL6 path in installation tree
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
Daniel Riek
Depends On:
  Show dependency treegraph
Reported: 2006-11-20 06:03 EST by Bastien Nocera
Modified: 2007-11-30 17:07 EST (History)
5 users (show)

See Also:
Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-12-15 09:03:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
anaconda_log.txt (134.21 KB, text/plain)
2006-12-05 10:10 EST, Bastien Nocera
no flags Details

  None (edit)
Description Bastien Nocera 2006-11-20 06:03:56 EST
RHEL5 Beta2 061111

Trying to do a default installation with evince selected:

13:42:51 DEBUG   : Adding Package patch - 2.5.4-29.2.2.ppc in mode u
13:42:51 DEBUG   : Member: m4.ppc 0-1.4.5-3 - u
13:42:51 DEBUG   : Adding Package m4 - 1.4.5-3.ppc in mode u
13:42:51 DEBUG   : Member: mesa-libGL.ppc64 0-6.5.1-7.fc6 - u
13:42:51 DEBUG   : Adding Package mesa-libGL - 6.5.1-7.fc6.ppc64 in mode u
13:42:51 DEBUG   : Member: libXxf86vm.ppc64 0-1.0.1-3.1 - u
13:42:51 DEBUG   : Adding Package libXxf86vm - 1.0.1-3.1.ppc64 in mode u
13:43:38 INFO    : Initial install time estimate = 7.33611448357
13:47:34 DEBUG   : Member: evince.ppc 0-0.6.0-6.el5 - u
13:47:34 WARNING : Try 1/10 for failed
13:47:34 WARNING : Try 2/10 for failed
13:47:34 WARNING : Try 3/10 for failed
13:47:34 WARNING : Try 4/10 for failed
13:47:34 WARNING : Try 5/10 for failed
13:47:34 WARNING : Try 6/10 for failed
13:47:34 WARNING : Try 7/10 for failed
13:47:34 WARNING : Try 8/10 for failed
13:47:34 WARNING : Try 9/10 for failed
13:47:34 WARNING : Try 10/10 for failed

This is probably already fixed, but I couldn't find any opened bugs about it.
Comment 1 RHEL Product and Program Management 2006-11-20 06:20:45 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
Comment 2 Dennis Gregorovic 2006-11-30 19:19:24 EST
Bastien, I can't figure out what would cause this.  Can you reproduce it or
provide more details?
Comment 3 Lonni J Friedman 2006-11-30 19:25:49 EST
I easily reproduce this.  Just attempt to install RHEL5-Client over http without
selecting any package groups.
Comment 4 Dennis Gregorovic 2006-11-30 19:31:54 EST
Chris, does this look familiar?  I'm wondering if it's an anaconda issue.
Comment 5 Lonni J Friedman 2006-11-30 19:34:54 EST
BTW, I have RH enterprise issue 107862 open for this as well.
Comment 6 Dennis Gregorovic 2006-11-30 20:31:29 EST
This looks to be an issue with anaconda and the split media URLs used in the
CD/DVD repodata.  Fortunately, a change for bz #214787 appears to fix this
problem as well. Reassigning to the anaconda component.
Comment 8 James Laska 2006-12-05 09:50:46 EST
I would need the /tmp/anaconda.log to be sure, but I believe the "rhel6" in the
message is the path the user selected to perform the http installation.

I suspect this is a urlmethod split media install, but I could be wrong.

The fragile nature of urlmethod split media isntalls can be observed in kbase,
for example:
 - http://kbase.redhat.com/faq/FAQ_105_9589.shtm
 - http://kbase.redhat.com/faq/FAQ_105_9588.shtm 

Please attach the /tmp/anaconda.log from the system at the time of this failure
so that we can better diagnose this issue.
Comment 9 Chris Lumens 2006-12-05 09:56:45 EST
Agreed, this install method is pretty fragile.  However I thought we already
fixed this problem.  If we could get a test run on the most recent tree
available and see the results from that, it'd be helpful.
Comment 10 Bastien Nocera 2006-12-05 10:10:46 EST
Created attachment 142854 [details]

Anaconda log from a failed installation.
Comment 11 James Laska 2006-12-05 10:35:51 EST
Okay, I believe this is the known issue of doing a split media urlmethod
 - This worked for beta2

If you add a installation number that grants you access to options (VT, Cluster,
ClusterStorage, Workstation, etc...) 
 - This failed for beta2

I suspect you are seeing the later.  If you do an installation w/o entering an
installation number ... I believe this will succeed.  You can then add the yum
repos post-install.  Alternatively, you can do an http installation from a
unified tree.
Comment 12 Lonni J Friedman 2006-12-05 10:40:23 EST
Nope, I still get the same failure even if I do not provide an installation number.
Comment 13 Evan McNabb 2006-12-05 15:55:05 EST
In response to comment #9: 

I see this issue in RHEL5-Server-20061111.0-x86_64 but not in
RHEL5-Server-20061201.0-x86_64. Can anyone else with access to the test build
verify this?
Comment 14 James Laska 2006-12-08 16:17:46 EST
Have *not* seen this problem on http, http loop back, nfs and nfsiso @everything
installs on ppc (as originally reported) against RHEL5-Server-20061207.4

Note You need to log in before you can comment on or make changes to this bug.