Bug 216432 - i386 cyrus-sasl-* plugin libraries not available for x86_64
i386 cyrus-sasl-* plugin libraries not available for x86_64
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: comps (Show other bugs)
6
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Luke Macken
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-20 08:25 EST by John Haxby
Modified: 2016-09-19 22:37 EDT (History)
3 users (show)

See Also:
Fixed In Version: 2.1.22-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-07 23:25:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Haxby 2006-11-20 08:25:09 EST
Description of problem:


Version-Release number of selected component (if applicable): 2.1.22-4

How reproducible:  Every time.


Steps to Reproduce:
1. Take some i386 program that uses cyrus-sasl for SASL authentication, install.
2. Attempt to install corresponding cyrus-sasl-{plain,md5,gssapi,ntlm,...} plugins.
  
Actual results:

Can't authenticate using any of the plug-in methods for the i386 application
even though the i386 cyrus-sasl-lib.i386 is installed.

Expected results:

Should be able to do "yum install cyrus-sasl-md5.i386", for example.

Additional info:

The various cyrus-sasl-* plugin RPMs were available in both i386 and x86_64
variants for FC5; for FC6 none of the plugins is aavailable for installation.  I
resorted to getting them off the FC6 i386 DVD, but that doesn't bode well for
future installations.

In addition, if I have an RPM that depends on, say, /usr/lib/sasl2/libcrammd5.so
(so that it can offer CRAMMD5 and DIGESTMD5 authentication mechanisms) then I
won't be able to "yum localinstall" it on FC6, whereas I could on FC5.

This looks like an oversight -- please can I have the i386 cyrus-sasl-* plugin
RPMs back?
Comment 1 Nalin Dahyabhai 2006-11-20 09:49:33 EST
Moving to "comps".
Comment 2 Dennis Gregorovic 2006-12-22 12:09:33 EST
took this by accident
Comment 3 Jesse Keating 2007-01-02 14:47:49 EST
This isn't actually a comps issue.  The issue is that the cyrus-sasl plugins
need to be marked as multilib, which they probably aren't right now.  To fix
this, we'll need to get Luke to mark them as multilib in the update tool, and
then generate an update of the package so that they'll go out in updates as
multilib.

Reassigning to Luke for now.
Comment 4 Luke Macken 2007-01-03 17:31:15 EST
I added cyrus-sasl-{md5,plain,sql,gssapi,ldap,ntlm}
 to the multilib list for ppc/x86_64.
Comment 5 Fedora Update System 2007-01-07 14:17:56 EST
cyrus-sasl-2.1.22-4 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.