Bug 216445 - Turkish font rendering is broken in kde./qt
Summary: Turkish font rendering is broken in kde./qt
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
(Show other bugs)
Version: 6
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-20 15:12 UTC by Sammy
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-21 16:30:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Firefox screenshot (628.75 KB, image/png)
2006-11-21 14:58 UTC, Sammy
no flags Details
konqueror screenshot (595.87 KB, image/png)
2006-11-21 14:59 UTC, Sammy
no flags Details
screenshot (489.62 KB, image/png)
2006-11-21 16:28 UTC, Ngo Than
no flags Details

Description Sammy 2006-11-20 15:12:06 UTC
Description of problem:

When I go to Turkish newspaper sites I see that certain characters,
specially "i" without a dot and uppoercase "I" with a dot is replaced
by a large blank space. This
was working fine in FC5. The same pages show fine in Firefox. Here is
an example:

 http://www.milliyet.com.tr/2006/11/20/index.html



Version-Release number of selected component (if applicable):

FC6 + updates

How reproducible:

Always

Steps to Reproduce:
1. Visit the above web site wtih konqueror and firefox.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Ngo Than 2006-11-20 21:56:27 UTC
i tried the obove steps to reproduce, but i did not see the different between 
konq and firefox! "i" and "I" rendering is correct!

Could you please attach the screenshot which shows the different? Thanks
Do you use the standard fonts (Sans/Mono)?

Comment 2 Sammy 2006-11-21 14:58:13 UTC
Created attachment 141769 [details]
Firefox screenshot

Comment 3 Sammy 2006-11-21 14:59:33 UTC
Created attachment 141770 [details]
konqueror screenshot

Comment 4 Ngo Than 2006-11-21 16:28:18 UTC
Created attachment 141786 [details]
screenshot

Comment 5 Ngo Than 2006-11-21 16:30:39 UTC
it's a user font setting issue. I assume you have not installed orselected the 
correct fonts. It works fine for me with the current FC6-update. Please take a 
look at above screenshot.

Comment 6 Sammy 2006-11-21 22:14:32 UTC
Could you tell me which ones are Turkish fonts. I have the same set of
fonts since FC5. I do have the x-fonts ISO8859-9 and the standard
truetype etc. In the past I don't remember having to do anything special.
I have been trying to hunt this down for many hours now!
Thanks

Comment 7 Ngo Than 2006-11-22 10:49:24 UTC
it's dejavu-lgc-fonts, which is included in FC6. For FC5, you can get it from 
Fedore Extras.

Comment 8 Sammy 2006-11-22 20:47:16 UTC
Well, I finally tracked it down to a number of type1 fonts I had. When I
simply install the type1 fonts from FC6 everything works fine. It must
be something weird with fontconfig. Now I can acutally use my Verdana
and Arial Turkish characters just fine as before.

Thanks for the help. I am too tired to track it down for fontconfig. Obviously
Firefox/pango/cairo is not effected by whatever was causing the problem.


Note You need to log in before you can comment on or make changes to this bug.