Bug 216447 - snd-azx sound driver broken in kernel 2.6.9-42.EL for Dell D820
snd-azx sound driver broken in kernel 2.6.9-42.EL for Dell D820
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brian Maly
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-20 10:50 EST by daryl herzmann
Modified: 2008-04-30 17:06 EDT (History)
1 user (show)

See Also:
Fixed In Version: 4.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-30 17:06:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
modprobe.conf (438 bytes, text/plain)
2006-12-06 16:33 EST, John W. Linville
no flags Details

  None (edit)
Description daryl herzmann 2006-11-20 10:50:50 EST
Hi,

I have a shiny new Dell D820 and there is no sound from kernels >= 2.6.9-42, but
2.6.9-34.0.2.ELsmp continues to work very nicely.  This bug is the identical to
bugzilla #202735

I've tested these kernels without success:
kernel-smp-2.6.9-42.EL
kernel-smp-2.6.9-42.0.2.EL
kernel-smp-2.6.9-42.0.3.EL
kernel-smp-2.6.9-42.23.EL  (from jbaron repo)
kernel-smp-2.6.9-42.22.EL.jwltest.175

lspci -v reports

00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition
Audio Controller (rev 01)
        Subsystem: Dell: Unknown device 01cc
        Flags: bus master, fast devsel, latency 0, IRQ 177
        Memory at dfffc000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 2
        Capabilities: [60] Message Signalled Interrupts: 64bit+ Queue=0/0 Enable-
        Capabilities: [70] Express Unknown type IRQ 0
        Capabilities: [100] Virtual Channel
        Capabilities: [130] Unknown (5)

thanks!
  daryl
Comment 1 John W. Linville 2006-12-04 16:50:30 EST
The most common cause of a problem like this is that the controls and outputs 
are improperly connected.  Have you tried unmuting and maximizing volume 
controls for both inputs and outputs?  If you do so, do you get any sounds at 
all?  What about with the speakers and/or headphones plugged-in to other 
jacks?

Please attach the output of running 'dmesg' just after attempting to play 
sound for the first time after a reboot.
Comment 2 daryl herzmann 2006-12-04 21:48:45 EST
Hi,

Thanks for the help.  Lets see, I'm trying 2.6.9-42.23.ELsmp at the moment.  I
try running gnome-volume-control and aumix, no sound.  Hmmm, the speaker is
onboard, so I don't think I have any cables to connect.  I tried muting and
un-muting.  Nothing comes to dmesg after trying sound the first time...

2.6.9-34.0.2.ELsmp continues to work....

thanks so much!  Sorry I'm not much more help here.
Comment 3 John W. Linville 2006-12-05 14:55:23 EST
Please try adding some lines like this to /etc/modprobe.conf:

   alias snd-card-0 snd-hda-intel
   options snd-hda-intel position_fix=1

You probably already have the first line anyway.  Do not replicate it, just 
add the options line.

Does this make things work better for you?
Comment 4 daryl herzmann 2006-12-05 18:57:54 EST
Hi,

Thanks for the continued help.  Currently, my /etc/modprobe.conf looks like:

alias eth0 tg3
alias scsi_hostadapter ata_piix
alias snd-card-0 snd-azx
options snd-card-0 index=0
options snd-had-intel model=3stack
install snd-azx /sbin/modprobe --ignore-install snd-azx && /usr/sbin/alsactl
restore >/dev/null 2>&1 || :
remove snd-azx { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; };
/sbin/modprobe -r --ignore-remove snd-azx
alias usb-controller ehci-hcd
alias usb-controller1 uhci-hcd
alias eth1 ipw3945


Hmm, note the "snd-had-intel", I don't think I added that.  So I added:

 options snd-hda-intel position_fix=1

to that file and fixed the "had" to 'hda'. and restarted...  nothing, sorry, but
thanks!
Comment 5 John W. Linville 2006-12-06 16:33:32 EST
Created attachment 142992 [details]
modprobe.conf

Let's try this modprobe.conf instead of the one you are currently using.
Comment 6 daryl herzmann 2006-12-06 23:44:29 EST
Hi,

thanks for the response.  Sorry, still no sound.  I surely hope I am not doing
something stupid, but a simple reboot into the old kernel continues to work.
Comment 8 daryl herzmann 2006-12-15 16:55:29 EST
Hi,

I've just tried 2.6.9-42.32.ELsmp from jbaron's repo and still no sound to be
heard.  I wish I was of more help.

daryl
Comment 9 daryl herzmann 2007-01-18 11:13:21 EST
Greetings,

I've just tried 2.6.9-42.40.ELsmp from jbaron's repo and no sound :(  I reboot
into kernel-smp-2.6.9-42.0.3.EL and sound works.  Any ideas?

thanks so much!
  daryl
Comment 10 daryl herzmann 2007-01-18 11:17:06 EST
Ooops, it is 2.6.9-34.0.2.ELsmp that continues to work.
Comment 11 daryl herzmann 2007-01-31 17:45:17 EST
Hi,

I asked on the nahant-list and got this kind response:

http://www.redhat.com/archives/nahant-list/2007-January/msg00344.html

with a link to this EXCELLENT page :)

http://people.redhat.com/stransky/alsa/

I built alsa-driver-1.0.13.RHEL4.tar.bz2 for 2.6.9-42.40.ELsmp  and now have
sound!  Yipeee!

I'll keep checking stock el4 kernels to see if sound comes back.  Thanks!

daryl
Comment 12 daryl herzmann 2007-03-12 13:16:45 EDT
Greetings,

I just gave 2.6.9-48.ELsmp (from beta channel) a spin and no sound is to be heard :(

I then built alsa-driver-1.0.13.RHEL4.tar.bz2 and now have sound, so at least
there is a workaround.

thanks,
  daryl
Comment 13 daryl herzmann 2007-05-01 16:27:49 EDT
Hi RedHat,

No love with el4.5's 2.6.9-55.ELsmp

built alsa-driver-1.0.13.RHEL4 again and I have sound.

daryl
Comment 14 daryl herzmann 2007-06-26 09:42:24 EDT
No love with 2.6.9-55.0.2.ELsmp , perhaps I should just bite the bullet and try
RHEL5 :)
Comment 15 Brian Maly 2007-06-26 10:35:48 EDT
We are planning on doing an ALSA update for 4.6 which should resolve most of the
sound issues. 
Comment 16 daryl herzmann 2007-06-26 16:19:59 EDT
Thanks Brian,

I broke down and upgraded to RHEL5 and sound works out of the box!   Yippee.

daryl
Comment 18 RHEL Product and Program Management 2008-02-28 11:29:34 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Note You need to log in before you can comment on or make changes to this bug.