Bug 216473 - system-config-rootpassword - rpm reports a lot of files missing
system-config-rootpassword - rpm reports a lot of files missing
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-rootpassword (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lubomir Rintel
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-20 12:59 EST by Michal Jaegermann
Modified: 2009-09-21 16:31 EDT (History)
0 users

See Also:
Fixed In Version: system-config-rootpassword-1.1.10-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-20 14:18:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2006-11-20 12:59:27 EST
Description of problem:

# rpm -V system-config-rootpassword
missing     /usr/share/system-config-rootpassword/passwordDialog.pyc
missing     /usr/share/system-config-rootpassword/rootpassword_tui.pyc
missing     /usr/share/system-config-rootpassword/system-config-rootpassword.pyc

This is really the same issue as bug 216471 but for a different package.

Version-Release number of selected component (if applicable):
system-config-rootpassword-1.1.9-1
Comment 1 Red Hat Bugzilla 2007-08-21 01:29:48 EDT
User pnasrat@redhat.com's account has been closed
Comment 2 Lubomir Kundrak 2007-11-20 04:57:51 EST
Michal: This is most likely not a bug in system-config-rootpassword, but a
corruption of the package in your installation. It could be caused by filesystem
corruption, terminating rpm, etc., etc.

Have you tried reinstalling the package? Does the problem still persist?
Comment 5 Michal Jaegermann 2007-11-20 12:56:59 EST
> Michal: This is most likely not a bug in system-config-rootpassword,
> but a corruption of the package in your installation.

Nope!  Preuinstall scriptlet in system-config-rootpassword used
to do 'rm -f /usr/share/system-config-rootpassword/*.pyc' or equivalent.
When updating with yum first a new package is getting installed
and later the old one removed in a cleanup phase.  This was removing
all these *.pyc packages and you had all that "missing".  As Python
code was still there the thing still worked.

This is actually explained in comments to bug 216471.  As I see
package scripts for system-config-rootpassword-1.1.10-1 are not
doing that any longer.  No idea if there could be yet some tools
written in Python which could have the same issue.  It was a while
from the original report.
Comment 6 Lubomir Kundrak 2007-11-20 13:40:39 EST
(In reply to comment #5)
> > Michal: This is most likely not a bug in system-config-rootpassword,
> > but a corruption of the package in your installation.
> 
> Nope!  Preuinstall scriptlet in system-config-rootpassword used
> to do 'rm -f /usr/share/system-config-rootpassword/*.pyc' or equivalent.

Sounds horribly. Thanks god it's no longer the case :)

> When updating with yum first a new package is getting installed
> and later the old one removed in a cleanup phase.  This was removing
> all these *.pyc packages and you had all that "missing".  As Python
> code was still there the thing still worked.
> 
> This is actually explained in comments to bug 216471.  As I see
> package scripts for system-config-rootpassword-1.1.10-1 are not
> doing that any longer.  No idea if there could be yet some tools
> written in Python which could have the same issue.  It was a while
> from the original report.

This was originally reported against F6, which is about to be EOLed. I can't see
those snippets in F7 or later. Is this still an issue for you, that has to be
solwed somehow or can I close the report?

Note You need to log in before you can comment on or make changes to this bug.