Bug 216487 - Missing acpi-cpufreq.ko file in Xen kernels
Missing acpi-cpufreq.ko file in Xen kernels
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: kernel-xen (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Xen Maintainance List
Brian Brock
:
: 216486 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-20 13:54 EST by Marcin Zajaczkowski
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-21 13:30:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcin Zajaczkowski 2006-11-20 13:54:44 EST
Description of problem:

Standard Xen kernel in FC6 and new one - kernel-xen-2.6.18-1.2849.fc6.i686.rpm
don't have acpi-cpufreq.ko module (*file is not available*). This causes lack of
"cpufreq".
This module is available in PAE kernel.

Are there any techinal limitations related with Xen in that field?


This problem can be related to bug 156893 or bug 212802, but there is rather
info about erros returned by module (like "No such device") not lack of module
at all.


Version-Release number of selected component (if applicable):
 - Standard Xen kernel in FC6
 - kernel-xen-2.6.18-1.2849.fc6.i686.rpm
Comment 1 Marcin Zajaczkowski 2006-11-20 13:57:35 EST
*** Bug 216486 has been marked as a duplicate of this bug. ***
Comment 2 Stephen Tweedie 2006-12-21 13:30:57 EST
Frequency scaling is not yet available under Xen.  Even if the CPU drivers
worked, there is no infrastructure in the host kernel's CPU frequency management
to take account of activity in guest Xen domains.

Note You need to log in before you can comment on or make changes to this bug.