Bug 216537 - Can't open .pdf file from evolution.
Can't open .pdf file from evolution.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: evolution (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-20 18:18 EST by Tom Kincaid
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version: RC
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-07 19:39:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This it the .PDF file that was sent to me. (14.30 KB, application/pdf)
2006-11-20 18:18 EST, Tom Kincaid
no flags Details
Acrobat Error. (338.14 KB, image/png)
2006-11-21 14:49 EST, Tom Kincaid
no flags Details
Error from document viewer. (259.74 KB, image/png)
2006-11-21 14:54 EST, Tom Kincaid
no flags Details
patch (1.31 KB, patch)
2006-12-01 23:47 EST, Matthias Clasen
no flags Details | Diff
Revised patch (1.55 KB, patch)
2006-12-06 12:24 EST, Matthew Barnes
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 219228 None None None Never
GNOME Desktop 383047 None None None Never

  None (edit)
Description Tom Kincaid 2006-11-20 18:18:31 EST
I am running RHEL 5 Beta 2 Client.

I received an e-mail with a .pdf attachment. I try to open the attachement with
both document view and Acrobat Reader. These are two options that are presented
me from Evolution.

When I do this I get a no such file or directory error from both document viewer
and Acrobat.

I have attached the screen shot and the pdf file. Note the pdf file has a .PDF
extentions (upper case) as opposed to a .pdf extension lower case.
Comment 1 Tom Kincaid 2006-11-20 18:18:31 EST
Created attachment 141708 [details]
This it the .PDF file that was sent to me.
Comment 2 Tom Kincaid 2006-11-21 14:49:21 EST
Created attachment 141817 [details]
Acrobat Error.
Comment 3 Tom Kincaid 2006-11-21 14:54:00 EST
Created attachment 141818 [details]
Error from document viewer.
Comment 4 Matthias Clasen 2006-12-01 22:57:04 EST
Mishandling the space in the filename ?
Comment 5 Matthias Clasen 2006-12-01 23:02:09 EST
Ah, no. In fact, it is the # in the filename that breaks things.
Comment 6 Matthias Clasen 2006-12-01 23:05:32 EST
When I tested this with an attachment named "test # 111.pdf", evince was called
with the argument

file:///home/mclasen/.evolution/cache/tmp/evolution-tmp-3K8rQ7/test_%23_111.pdf

but looking in that directory, I find a file named test_
Comment 7 Matthias Clasen 2006-12-01 23:45:56 EST
I believe the problem is that for viewing attachments, evo calls
em_utils_temp_save_part(), which constructs a temp path and passes it
on to mail_save_part(), which defers the acutal saving to a thread that
calls save_part_save(), which treats the path as an uri and passes
it into camel_stream_vfs_new_with_uri(). 

The attached (untested) patch should fix the issue.
Comment 8 Matthias Clasen 2006-12-01 23:47:31 EST
Created attachment 142657 [details]
patch
Comment 9 RHEL Product and Program Management 2006-12-02 00:01:09 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 10 Matthew Barnes 2006-12-06 11:32:13 EST
Forwarded this upstream:
http://bugzilla.gnome.org/show_bug.cgi?id=383047
Comment 11 Matthew Barnes 2006-12-06 12:24:31 EST
Created attachment 142968 [details]
Revised patch

Verified mclasen's patch and did a bit of extra code cleanup.

Here's what I submitted upstream.
Comment 12 Matthew Barnes 2006-12-06 17:05:16 EST
Fixed in evolution-2.8.0-22.el5.
Comment 13 Rod Nayfield 2006-12-14 16:04:32 EST
This patch breaks the ability to save attachements.

Cannot save attachements with 2.8.0-22.  backed down to 2.8.0-21 and it works

Comment 14 Matthew Barnes 2006-12-15 12:31:25 EST
Confirmed that both patches (mclasen's and mine) cause bug #219228.

There's no time to investigate this further before RHEL-5 GA, so the best we can
do revert the patch that caused the regression and defer this to RHEL-5.1.

Hence, Devel_NACK.

Patch disabled in evolution-2.8.0-30.el5.
Comment 15 RHEL Product and Program Management 2007-02-07 19:39:58 EST
A package has been built which should help the problem described in 
this bug report. This report is therefore being closed with a resolution 
of CURRENTRELEASE. You may reopen this bug report if the solution does 
not work for you.

Note You need to log in before you can comment on or make changes to this bug.