Bug 216601 - gnome-settings-daemon crashes if ~/.Xdefaults exists but is not accessible
gnome-settings-daemon crashes if ~/.Xdefaults exists but is not accessible
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gnome-core (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Denise Dumas
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-21 02:45 EST by Stephan Wiesand
Modified: 2014-06-23 07:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:20:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephan Wiesand 2006-11-21 02:45:58 EST
Description of problem:

If ~/.Xdefaults exists but gnome-settings-daemon can't access it, it will crash.

Version-Release number of selected component (if applicable):

% rpm -qf /usr/libexec/gnome-settings-daemon
control-center-2.16.0-11.el5.x86_64

How reproducible:
100%

Steps to Reproduce:
1. touch ~/.Xdefaults
2. chmod 000 ~/.Xdefaults
3. log in to a new gnome session
  
Actual results:
A dialog box telling the user that his session may not work as expected.

Expected results:


Additional info:
Comment 2 Matěj Cepl 2008-11-19 05:41:04 EST
Shouldn't this be reassigned to Bastien?
Comment 3 cyrushmh 2010-04-30 01:58:55 EDT
#yum --enablerepo=updates-testing update




正在升级       : gnome-settings-daemon-2.30.1-3.fc13.i686                                                                                             5/16 
I/O warning : failed to load external entity "/etc/gconf/schemas/apps_gnome_settings_daemon_screensaver.schemas"
打开“/etc/gconf/schemas/apps_gnome_settings_daemon_screensaver.schemas”失败:没有那个文件或目录


2.6.33.2-57.fc13.i686.PAE
Comment 6 RHEL Product and Program Management 2014-03-07 08:45:41 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 7 RHEL Product and Program Management 2014-06-02 09:20:07 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.