Bug 21662 - g++: Internal error: Segmentation fault
g++: Internal error: Segmentation fault
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-03 17:28 EST by bastiaan
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-06 09:36:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bastiaan 2000-12-03 17:28:36 EST
The following (invalid) code generates a segfault:

class ConstBug {
    public: 
    static void doBug();
};

void ConstBug::doBug() const {
}

$ g++ -c constbug.cpp
constbug.cpp:6: Internal error: Segmentation fault.
Comment 1 Jakub Jelinek 2000-12-06 09:36:27 EST
Typo, which seems to be fixed by:
2000-10-20  Jeffrey Oldham  <oldham@codesourcery.com>

        * decl.c (revert_static_member_fn): Fixed typo.
in CVS gcc, have just added it to our patchset and it will appear in
gcc-c++-2.96-65

Note You need to log in before you can comment on or make changes to this bug.