Bug 216640 - link speed shows Not Available under Devices option in gnome-nettool
link speed shows Not Available under Devices option in gnome-nettool
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gnome-nettool (Show other bugs)
5.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
desktop-bugs@redhat.com
: OtherQA
Depends On:
Blocks: 574519 743405 223278
  Show dependency treegraph
 
Reported: 2006-11-21 05:11 EST by Giribabu Bikki
Modified: 2013-07-14 21:23 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-14 21:23:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Changes done to mii.h and util-mii.c (1.30 KB, patch)
2007-06-08 02:55 EDT, Narendra K
no flags Details | Diff

  None (edit)
Description Giribabu Bikki 2006-11-21 05:11:24 EST
Description of problem:gnome-nettool shows unknown link spped in Devices option


Version-Release number of selected component (if applicable):2.16.0


How reproducible:


Steps to Reproduce:
1. install RHEL5-beta2
2. install gnome-nettool rpm
3. run gnome-nettool command from terminal
4. observe link speed says 'Not Available' under devices tab for any up ethernet   
   links 
  
Actual results:link speed says not available


Expected results: it should show correct link speed


Additional info:
Comment 1 Samuel Benjamin 2006-11-29 08:20:51 EST
Dell has requested this fix to be included in 5.0 and it is on their weekly
status watch list. RH Engineering attention requested.
Comment 2 RHEL Product and Program Management 2006-11-29 08:30:20 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Matthias Clasen 2006-11-29 13:36:42 EST
My quick run in gdb seems to indicate that 

        if (ioctl (sock, SIOCGMIIPHY, &ifr) < 0) {

in mii_get_basic returns something other than ENODEV so that we treat the
device as a wireless device, That seems to happen for both lo and eth0 here.
 
Comment 4 Samuel Benjamin 2006-12-06 14:45:52 EST
On Dell's weekly watch list. Need engineering update on fix. Thanks.
Comment 5 Giribabu Bikki 2006-12-07 01:28:32 EST
SIOCGMIIPHY finally defined as SIOCDEVPRIVATE in mii.h of gnome-nettool and the
ioctl on SIOCDEVPRIVATE retriving from 0x89f0 instead of 0x8947. I tried with
ioctl on 0x8947 and my link speed is showing up as 100BaseT4
Comment 6 Matthias Clasen 2006-12-07 12:39:30 EST
Re Comment #4: no update on a fix available, sorry. With the information in
comment #5 it appears we may just need to copy uptodate ioctl numbers from 
/usr/include/linux/sockios.h.

I'll ask Chris to investigate when he is back.
Comment 8 Amit Bhutani 2006-12-20 05:05:01 EST
Mathias/Chris- Any update on this one ? Since you have a good idea on what the
fix is, can one of you post patch and attempt to incorporate in RHEL5.0 ??
Comment 9 Larry Troan 2007-01-03 17:10:44 EST
NOT A BLOCKER:
Per telecon with Sue Denham (RH), Larry Troan (RH), John Hull (Dell) and Dale
Kaisner (Dell) on 1/02/07, Dell does NOT view this bug as a BLOCKER for RHEL5 GA.

Comment 10 Larry Troan 2007-01-18 09:11:13 EST
Setting 5.1 flag=? and resetting 5.1 flag.
Comment 11 Narendra K 2007-02-28 09:06:45 EST
Any  update on the patch mentioned in the comment #6 ?
Comment 12 RHEL Product and Program Management 2007-05-10 13:28:51 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 14 Narendra K 2007-06-08 02:55:23 EDT
Created attachment 156553 [details]
Changes done to mii.h and util-mii.c

Patch for review.
Comment 17 Larry Troan 2007-07-26 08:11:01 EDT
On Thu, 2007-07-26 at 10:26 +0530, Charles_Rose@Dell.com wrote:
Yes, it is fine to move this to RHEL 5.2.
> 
> Thanks,
> Charles
> +91-80-280-77147

Removing 5.1 flag and setting 5.2 flag to ?.
This is a bug so not setting Feature Tracker bug "Dell5.2FB."
Raising priority for 5.2.
Comment 21 Narendra K 2007-11-06 06:30:02 EST
The patch has been accepted upstream. Pls refer to the bugzilla BZ 451925 on 
gnome bugzilla below.
         http://bugzilla.gnome.org/show_bug.cgi?id=451925 and 
         http://svn.gnome.org/viewvc/gnome-nettool/trunk/src/ Rev 687 which 
fixes the BZ 451925.
          
Comment 25 RHEL Product and Program Management 2008-09-19 17:53:09 EDT
This bugzilla was reviewed by QE as a non-FasTrack request.
It has since been proposed for FasTrack. The qa_ack has 
been reset. QE needs to re-review this bugzilla for FasTrack.
Comment 41 Dan Williams 2013-07-14 21:23:27 EDT
This should be fixed in the latest release of Red Hat Enterprise Linux 6; if it's not, please re-open so we can prioritize and schedule it.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.