Bug 216648 - Exception on adding a route
Exception on adding a route
Status: CLOSED DUPLICATE of bug 211980
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-network (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Depends On:
Blocks: 200812
  Show dependency treegraph
Reported: 2006-11-21 07:13 EST by Giribabu Bikki
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-11-29 10:28:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Exception Message Image (114.48 KB, image/png)
2006-11-28 17:25 EST, Amit Bhutani
no flags Details

  None (edit)
Description Giribabu Bikki 2006-11-21 07:13:09 EST
Description of problem:An unhandled exception on adding a route

Version-Release number of selected component (if applicable):1.3.95-1

How reproducible:

Steps to Reproduce:
1. install RHEL5-beta2
2. run system-config-network
3. select Edit->Route
4. add a route and click ok
5. an unhandled exception is occured

Actual results: exception

Expected results: route to be added with out errors

Additional info:
Comment 1 Amit Bhutani 2006-11-28 17:25:50 EST
Created attachment 142335 [details]
Exception Message Image
Comment 2 Amit Bhutani 2006-11-28 17:26:55 EST
Pasting the exact exception message in text format as well:

Component: system-config-network
Version: 1.3.95
Summary: TB94e1a8fa sharedtcpip.py:176:route_update:TypeError: sequence item not
a string or unicode object

Traceback (most recent call last):
  File "/usr/share/system-config-network/netconfpkg/gui/sharedtcpip.py", line
284, in on_routeAddButton_clicked
    route_update(xml, device)
  File "/usr/share/system-config-network/netconfpkg/gui/sharedtcpip.py", line
176, in route_update
    clist.append([route.Address, route.Netmask, route.Gateway])
TypeError: sequence item not a string or unicode object

Local variables in innermost frame:
device: Device.AutoDNS=false

xml: <glade.XML object (PyGladeXML) at 0x2aaab5072b40>
route: Route.Gateway=['']

clist: <gtk.CList object (GtkCList) at 0x2aaab29b6af0>
Comment 3 Samuel Benjamin 2006-11-29 08:18:57 EST
Dell has requested this fix to be included in 5.0 and it is on their weekly
status watch list. Engineering attention requested.
Comment 4 RHEL Product and Program Management 2006-11-29 08:30:15 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
Comment 5 Harald Hoyer 2006-11-29 10:28:47 EST

*** This bug has been marked as a duplicate of 211980 ***
Comment 6 Giribabu Bikki 2006-12-07 02:28:33 EST
I regressed with system-config-network-1.3.96-1 and it seems this bug has been fixed

Note You need to log in before you can comment on or make changes to this bug.