Bug 216654 - Update libgpod for newer ipod support
Update libgpod for newer ipod support
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: libgpod (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bastien Nocera
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-21 07:59 EST by Alexander Larsson
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: RC
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-07 19:42:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alexander Larsson 2006-11-21 07:59:53 EST
The libgpod version we're shipping currently is quite old. It doesn't support
newer ipods, nor does it support old ipods that have been used with iTunes 7 (in
fact, that causes rhythmbox to crash). It also has several crasher bugs reported
against it.

As only rhythmbox in RHEL5 depends on this I propose that we upgrade it to a new
version (0.4.0 or possibly 0.4.1 if that gets released).

We're planning to do the same in an FC6 update, but that is a bit more tricky,
since we released FC6 with the older version and they are not ABI compatible.
See bug 211648 for details.
Comment 1 RHEL Product and Program Management 2006-11-21 08:20:22 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 2 Alexander Larsson 2006-11-28 10:16:09 EST
Any chance we can get a qa ack on this?
Without it rhythmbox crashes whenever you access a recent ipod or any ipod used
with iTunes7.
Comment 3 Alexander Larsson 2006-11-28 10:58:04 EST
Built as libgpod-0_4_0-1_el5
Comment 4 RHEL Product and Program Management 2007-02-07 19:42:10 EST
A package has been built which should help the problem described in 
this bug report. This report is therefore being closed with a resolution 
of CURRENTRELEASE. You may reopen this bug report if the solution does 
not work for you.

Note You need to log in before you can comment on or make changes to this bug.