Bug 2166954 - Touchpad not working beginning with Kernerl 6.1 on Tablet ASUS T101HA-GR029T
Summary: Touchpad not working beginning with Kernerl 6.1 on Tablet ASUS T101HA-GR029T
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 37
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2023-02-03 16:36 UTC by mail
Modified: 2023-02-03 17:14 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-02-03 17:14:44 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
Journalctl and lsmod of working and not-working kernel (208.02 KB, text/plain)
2023-02-03 16:36 UTC, mail
no flags Details

Description mail 2023-02-03 16:36:40 UTC
Created attachment 1942083 [details]
Journalctl and lsmod of working and not-working kernel

1. Please describe the problem:
I am using a small Notebook/Tablet ASUS T101HA-GR029T since Fed33.
All was working fine - Keyboard, Touchpad, Touchscreen.

Beginning with Kernel 6.1 Touchpad is not working, so no mouse movement via Touchpad is possible. Keyboard and Touchpad working as before.

Latest working kernel is 6.0.18-300.

See also:
https://ask.fedoraproject.org/t/touchpad-not-working-after-update-to-newer-kernel-in-fed36-37/30990


2. What is the Version-Release number of the kernel:
Working: 6.0.18-300
Not working: 6.1.8-200


3. Did it work previously in Fedora? If so, what kernel version did the issue
   *first* appear?  Old kernels are available for download at
   https://koji.fedoraproject.org/koji/packageinfo?packageID=8 :
First realized with Kernel 6.1.6-200


4. Can you reproduce this issue? If so, please provide the steps to reproduce
   the issue below:
Load Kernel 6.0.18-300 ==> working
Load Kernel 6.1.8-200 ==> not working


5. Does this problem occur with the latest Rawhide kernel? To install the
   Rawhide kernel, run ``sudo dnf install fedora-repos-rawhide`` followed by
   ``sudo dnf update --enablerepo=rawhide kernel``:
Not tested yet, because I am fearing to compromise my Tablet.


6. Are you running any modules that not shipped with directly Fedora's kernel?:
No.


7. Please attach the kernel logs. You can get the complete kernel log
   for a boot with ``journalctl --no-hostname -k > dmesg.txt``. If the
   issue occurred on a previous boot, use the journalctl ``-b`` flag.
See attached log file for "working" and "not-working".
journalctl --no-hostname -k and lsmod

Comment 1 Hans de Goede 2023-02-03 17:14:44 UTC
This is my bad, I accidentally broke SW_TABLET_MODE reporting on the Asus T100* and T101* series and it is now reporting that it is in tablet mode while it is actually docked and thus in laptop mode.

This is causing libinput to suppress touchpad events, as it would for a 360° hinges style 2 in 1 with the keyboard + touchpad folded behind the display (so in tablet mode).

I recently hit this myself on a T101HA and a fix for this has already been merged for 6.2-rc6:

"platform/x86: asus-wmi: Fix kbd_dock_devid tablet-switch reporting"

https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=fdcc0602d64f22185f61c70747214b630049cc33

And the fix for this has been merged into 6.1.9, which currently is in updates-testing.

You can install 6.1.9 by running:

sudo dnf upgrade --enablerepo=updates-testing --refresh 'kernel*'

That should fix this, if not let me know.


Note You need to log in before you can comment on or make changes to this bug.