Bug 216714 - hwbrowser is unable to start
hwbrowser is unable to start
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: hwbrowser (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
David Lawrence
:
: 219177 (view as bug list)
Depends On:
Blocks: 200812
  Show dependency treegraph
 
Reported: 2006-11-21 12:46 EST by Leonid Kanter
Modified: 2009-06-19 06:03 EDT (History)
2 users (show)

See Also:
Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-10 21:06:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
sosreport (449.98 KB, application/x-bzip)
2006-11-21 12:46 EST, Leonid Kanter
no flags Details

  None (edit)
Description Leonid Kanter 2006-11-21 12:46:24 EST
Description of problem:


[root@localhost ~]# hwbrowser
Traceback (most recent call last):
  File "/usr/share/hwbrowser/DeviceList.py", line 232, in ?
    reread_device_type_list ()
  File "/usr/share/hwbrowser/DeviceList.py", line 171, in reread_device_type_list
    list.set (iter, 0, hardware.get_category_string (key), 1, key)
  File "/usr/share/hwbrowser/DeviceList.py", line 109, in get_category_string
    return self.type_mapping[key]
KeyError: 4194304

Version-Release number of selected component (if applicable):


How reproducible:

always
hwbrowser-0.27-2
Comment 1 Leonid Kanter 2006-11-21 12:46:25 EST
Created attachment 141799 [details]
sosreport
Comment 2 Nils Philippsen 2006-11-22 11:32:49 EST
I've built hwbrowser-0.29-1.el5 in RHEL5 which should contain a fix for this --
it should recognize ATA-, SATA-controllers now as well as be more gracious about
unknown device classes. You can download the package I built for testing from:

http://people.redhat.com/nphilipp/.private/hwbrowser-0.29-1.el5.noarch.rpm

Note that the package isn't signed, its checksums are:

MD5SUM: 0be7810d82cfb181fb66f715bbeb531e
SHA1SUM: 5521eb9e7b8a77d2c09a106939ac967ca79f194e

Please report back whether this fixes your problem.
Comment 3 Leonid Kanter 2006-11-23 03:43:55 EST
hwbrowser-0.29-1.el5 is OK.
Comment 4 RHEL Product and Program Management 2006-11-27 21:41:25 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 5 RHEL Product and Program Management 2006-11-27 21:41:26 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 6 Nils Philippsen 2006-12-12 10:06:31 EST
*** Bug 219177 has been marked as a duplicate of this bug. ***
Comment 7 John Feeney 2006-12-14 16:22:06 EST
Even there seems to be a fix for this bug, Dell wants to make sure that this is
shipped in 5.0.0 and fixes their i386 systems. Thus Dell wants it to be a
blocker for 5.0.0.
Comment 9 Rezwanul Kabir 2006-12-18 12:00:15 EST
hwbrowser in comment#3 resolves bug 219177 as well.
Comment 10 Amit Bhutani 2007-01-10 13:27:37 EST
Marking VERIFIED based on comment #9 plus the fact that RCS6 has later version
0.30-1.el5.
Comment 11 Amit Bhutani 2007-01-10 13:37:46 EST
RH- Please close based on comments #9 and #10. Thanks.

Note You need to log in before you can comment on or make changes to this bug.